jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Reschke (JIRA)" <j...@apache.org>
Subject [jira] Updated: (JCR-540) AbstractJCRTest fails on level 1 repositories
Date Thu, 10 Aug 2006 17:10:16 GMT
     [ http://issues.apache.org/jira/browse/JCR-540?page=all ]

Julian Reschke updated JCR-540:
-------------------------------

    Attachment: JCR-540.diff.txt

New proposed patch, not using NotExecutableException.

I'd still like to see an easy way to find out whether a repository supports L1 completely.
Did I miss something? If not, should I open a separate issue?


> AbstractJCRTest fails on level 1 repositories
> ---------------------------------------------
>
>                 Key: JCR-540
>                 URL: http://issues.apache.org/jira/browse/JCR-540
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: JCR TCK
>            Reporter: Julian Reschke
>            Priority: Minor
>         Attachments: JCR-540.diff.txt, JCR-540.diff.txt
>
>
> If a test case indicates that it's not read-only, org.apache.jackrabbit.test.AbstractJCRTest
tries to cleanup the test root in the setUp method. This will cause the test case to fail,
because a Level 1 repository will throw an UnsupportedOperationException here.
> Proposal: before trying the cleanup, check for L2 functionality and throw a NotExecutableException
otherwise:
>             if (! isSupported(Repository.LEVEL_2_SUPPORTED)) {
>               cleanUp();
>               String msg = "Test case requires level 2 functionality";
>               throw new NotExecutableException(msg);
>             }

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message