jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-521) Add a method public boolean hasNodeType(String name) in NodeTypeManagerImpl
Date Fri, 28 Jul 2006 21:40:14 GMT
    [ http://issues.apache.org/jira/browse/JCR-521?page=comments#action_12424180 ] 
Jukka Zitting commented on JCR-521:

Two stylistic issues still. (I'm probably more strict with you than with a random contributor,
but please bear with me. :-)

a) Using "this." is usually redundant in normal method calls, unless you explicitly want to
draw attention to the fact that a method is invoked on "this".

b) There are two extra empty lines being added by your patch. While they do no harm, it is
generally a good practice to trim any unnecessary modifications out of your patches before
submitting them. Less clutter makes it easier to review the patch.

> Add a method public boolean hasNodeType(String name) in NodeTypeManagerImpl
> ---------------------------------------------------------------------------
>                 Key: JCR-521
>                 URL: http://issues.apache.org/jira/browse/JCR-521
>             Project: Jackrabbit
>          Issue Type: New Feature
>          Components: nodetype
>            Reporter: Nicolas Toper
>         Assigned To: Jukka Zitting
>            Priority: Trivial
>             Fix For: 1.1
>         Attachments: patch060728-2.txt, patch060728.txt
> As seen in the ML, we plan to add this method and update this class and the interface

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message