jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tobias Bocanegra (JIRA)" <j...@apache.org>
Subject [jira] Created: (JCR-476) Remove recently added getJCRPath()/getQPath() from NamespaceResolver
Date Wed, 12 Jul 2006 10:33:30 GMT
Remove recently added getJCRPath()/getQPath() from NamespaceResolver

         Key: JCR-476
         URL: http://issues.apache.org/jira/browse/JCR-476
     Project: Jackrabbit
        Type: Improvement

    Versions: 1.1    
    Reporter: Tobias Bocanegra
 Assigned to: Tobias Bocanegra 
    Priority: Minor

issue JCR-473 added 2 new methods to NamespaceResolver: 

    public Path getQPath(String jcrPath) throws MalformedPathException;
    public String getJCRPath(Path qPath) throws NoPrefixDeclaredException;

which do not belong here, since the NamespaceResolver has nothing to do with paths. suggest
to remove them.

further is the naming of the QName related methods a bit vague. suggest to rename them to:

   QName parseName(String jcrName)
   String formatName(QName qName)

(although they do not belong here either, but helps to leverage evt. caching namespace resolvers).

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message