jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miro Walker" <miro.wal...@cognifide.com>
Subject RE: BackupTool Main Class
Date Mon, 26 Jun 2006 10:28:14 GMT
"backup" is the opposite of "restore", while "load" is the opposite of
"save". To mix the two different metaphors makes the naming asymmetric,
which is confusing.

Miro

-----Original Message-----
From: Nicolas Toper [mailto:ntoper@gmail.com] 
Sent: 26 June 2006 11:02
To: dev@jackrabbit.apache.org; tobias.bocanegra@day.com
Subject: Re: BackupTool Main Class

Sorry Tobias what do you mean by "save/restore are no symmetric"?

About the input/outputStream: agreed. They will be FileInput/Ouput so I
can
use NIO.

On 6/26/06, Tobias Bocanegra <tobias.bocanegra@day.com> wrote:
>
> > I'd put the save/restore methods in RepositoryImpl (and later on
> > probably also in the JackrabbitRepository interface) and let the end
> > user decide how to call them.
> save/restore are no symmetric. backup/restore, save/load,
> export/import, would be. i would prefer a
> RepositoryImpl.getBackupManager() call, that then can have whatever
> methods make sense.
>
> btw: i don't like the Input/Output streams on the save/restore
> methods. especially when dealing with large repositories, you will
> need java.nio, split-files, etc.
>
> regards, toby
> --
> -----------------------------------------< tobias.bocanegra@day.com
>---
> Tobias Bocanegra, Day Management AG, Barfuesserplatz 6, CH - 4001
Basel
> T +41 61 226 98 98, F +41 61 226 98 97
> -----------------------------------------------< http://www.day.com
>---
>



-- 
a+
Nico
my blog! http://www.deviant-abstraction.net !!

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

Mime
View raw message