jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: Can't get Jackrabbit to work with Lucene 2.0.0
Date Tue, 06 Jun 2006 06:44:38 GMT
Hi,

On 6/6/06, Chan Chin Wei <chanchinwei@stee.stengg.com> wrote:
> I understand that Lucene is required to run the Jackrabbit in my web
> applicaiton.  However, the version of the Lucene used in Jackrabbit is
> 1.4.3, and the Lucene version that my web application is using Lucene
> 2.0.0.  Therefore, instead of using Lucene 1.4.3 jar, Lucene 2.0.0 jar
> is used instead.  But, I get errors when I tried to startup my tomcat.
>
> Does that means Jackrabbit is not workable with Lucene 2.0.0?

Unfortunately yes. There is a backwards compatibility issue in Lucene
1.9 and 2.0 that causes the Jackrabbit to fail with the exception you
encountered. See the following bug reports for more details:

    http://issues.apache.org/jira/browse/JCR-352
    http://issues.apache.org/jira/browse/LUCENE-523

I think the best workaround for now is to deploy Jackrabbit as a
separate web application (using the jackrabbit-server war) or as a JCA
resource (using the jackrabbit-jca rar) and access it through JNDI in
your application. This allows Jackrabbit to have it's own class loader
with Lucene 1.4.3 while your application can keep using Lucene 2.0.0.

BR,

Jukka Zitting

-- 
Yukatan - http://yukatan.fi/ - info@yukatan.fi
Software craftsmanship, JCR consulting, and Java development

Mime
View raw message