jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Guggisberg (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-367) Remove dependency on Xerces
Date Wed, 28 Jun 2006 15:42:30 GMT
    [ http://issues.apache.org/jira/browse/JCR-367?page=comments#action_12418264 ] 

Stefan Guggisberg commented on JCR-367:

Comment by Felix Meschberger [28/Jun/06 03:23 PM]  
> Hmm, no, but as the new code relies on JAXP, which is part of the J2SE API since 1.4.
I assume, this code is correct in both 1.4 and 1.5 I have to assume, right ? Correct me if
I am wrong.

well, just a example: the public class org.apache.xml.utils.XMLChar is part of the 1.4 jre
but it doesn't exist in jre 1.5.

> ... Is this kind of test a requirement for fixes ? 

it's IMO common sense to thoroughly test changes with significant potential impact on public
api mehtods
and unknown side effects, especially if they replace time-tested code.

> ... as I have confidence in Sun - else I could not even use the java.lang.String class

well then consider the XMLChar case above...

> Remove dependency on Xerces
> ---------------------------
>          Key: JCR-367
>          URL: http://issues.apache.org/jira/browse/JCR-367
>      Project: Jackrabbit
>         Type: Improvement

>   Components: xml
>     Reporter: Michael Young
>  Attachments: No_Xerces_Patch.fm.20060627.patch
> Classloaders in certain J2EE servers do not play well with the Xerces requirement

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message