jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandeep Warikoo" <warikoo.sand...@gmail.com>
Subject Re: [jira] Created: (JCR-404) Unable to compile jackrabbit source code
Date Thu, 20 Apr 2006 09:36:01 GMT
Hi Marcel,

I have been able to build jackrabbit successfull after re-downloading the
those jar files. I think the problem may have arised as those jar files got
downloaded using 1.1-beta-2 version.

Thanks for all the help during last two days.


On 4/20/06, Marcel Reutegger <marcel.reutegger@gmx.net> wrote:
>
> seems like you have a corrupt jar file. you should delete it from your
> local maven repository and let maven download it again.
>
> regards
> marcel
>
> Sandeep Warikoo wrote:
> > Hi Marcel,
> >
> > When I tried to view contents of commons-collections-3.1.jar through
> "jar tf
> > commons-collections-3.1.jar", I got followig error in it:
> >
> >
> ************************************************************************************
> > java.io.EOFException: Unexpected end of ZLIB input stream
> >  at java.util.zip.InflaterInputStream.fill(InflaterInputStream.java:215)
> >  at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:134)
> >  at java.util.zip.ZipInputStream.read(ZipInputStream.java:139)
> >  at java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:91)
> >  at sun.tools.jar.Main.list(Main.java:744)
> >  at sun.tools.jar.Main.run(Main.java:192)
> >  at sun.tools.jar.Main.main(Main.java:904)
> >
> **************************************************************************************
> >
> > Could this be the cause of build problem?
> >
> > I have attached the entire output of "jat tf" with this mail.
> >
> >
> > On 4/19/06, Marcel Reutegger <marcel.reutegger@gmx.net> wrote:
> >> Sandeep Warikoo wrote:
> >>> Hi,
> >>>
> >>> Though I am not familiar my maven, here is a snippet from
> project.xmlwhich
> >>> shows the version used is 3.1
> >>>
> >>>
> >>>
> >>
> **************************************************************************************
> >>>         <dependency>
> >>>             <!-- Commons Collections -->
> >>>             <groupId>commons-collections</groupId>
> >>>             <artifactId>commons-collections</artifactId>
> >>>             <version>3.1</version>
> >>>             <url>http://jakarta.apache.org/commons/collections/</url>
> >>>             <!--
> >>>                 Advanced collection classes, utilities and data
> >> structures
> >>>                 used internally by Jackrabbit.
> >>>             -->
> >>>         </dependency>
> >>>
> >>
> ************************************************************************************
> >>> I had installed jackrabbit code base using svn (svn checkout
> >>> http://svn.apache.org/repos/asf/jackrabbit/trunk/jackrabbit) as per
> >>> instructions given at http://jackrabbit.apache.org/doc/building.html .
> >>>
> >>> I did some search on my hard disk and it looks like it had installed
> >> those
> >>> dependent libraries at home folder.
> >>>
> >>> I can find the common collection jar at: C:\Documents and
> >>> Settings\sandeep_warikoo\.maven\repository\commons-collections\jars
> >>>
> >>> Did I miss dome default over-ridding?
> >> looks like everything is ok. If you are not able to build jackrabbit
> >> from the sources and still want to get started, I suggest you use the
> >> 1.0 release:
> >> http://jackrabbit.apache.org/downloads.cgi
> >>
> >> regards
> >> marcel
> >>
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message