jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ross Black (JIRA)" <j...@apache.org>
Subject [jira] Created: (JCR-413) JCA will not compile with J2EE1.3 classes
Date Wed, 26 Apr 2006 02:49:03 GMT
JCA will not compile with J2EE1.3 classes
-----------------------------------------

         Key: JCR-413
         URL: http://issues.apache.org/jira/browse/JCR-413
     Project: Jackrabbit
        Type: Bug

  Components: jca  
    Versions: 1.0    
 Environment: JDK1.4.2
SunOne AppServer 7
    Reporter: Ross Black
    Priority: Minor


In JCAManagedConnectionFactory, the constructor invoked to throw ResourceException does not
exist under J2EE1.3 / JCA1.1 classes.
 throw new ResourceException(e)  -  line 136 and line 277.

Instead the code needs to do something like:

            ResourceException exception = new ResourceException("Failed to create session");
            exception.setLinkedException(e);
            throw exception;

This will allow it to compile/run under J2EE1.3


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message