jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cedric Bosdonnat <cbosdon...@nuxeo.com>
Subject Re: Using JCR-RMI with the jackrabbit-server
Date Mon, 24 Apr 2006 09:13:41 GMT
Hi Felix,

Felix Meschberger a écrit :

> Actually - from what I can see in the log - the repository should be
> registered with RMI:
> 
>    24.04.2006 10:19:22 *INFO * RepositoryStartupServlet: Repository
>    bound via RMI with name: //localhost:1099/jackrabbit.repository
>    (RepositoryStartupServlet.java, line 475)
> 
> The log entry for the dump is only informative as the repository startup
> servlet tries to create an RMI registry first and falls back to
> connecting to an existing registry if creation fails. Therefore failure
> to create the registry is not an error. The next entry though is
> actually, what you are looking for: The confirmation, that from the
> point of view of the startup servlet, the repository should be
> registered under the logged URL.

In fact, this error seems to indicate some problem during the registry
creation: I ran tomcat as a normal user and got this log. However, I
tried to run Tomcat as root and I didn't get the error. I even saw the
following entry in the netstat output:

tcp        0      0 localhost:rmiregistry   *:*        LISTEN

Running the test works fine afterwards using the 1099 port. It seems to
be a problem of priviledges to open such a port. It might be a
privileged port IIRC.

Moreover I found the following problem after shutting down tomcat: the
rmiregistry entry in netstat is still printed: the port isn't closed :(
and there is a java process still running (it seems to be a Tomcat
problem). When I kill this process, the port is closed...


Thanks for your help
Cedric

Mime
View raw message