jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <Felix.Meschber...@day.com>
Subject Re: Using JCR-RMI with the jackrabbit-server
Date Mon, 24 Apr 2006 08:46:37 GMT
Hi Cedric,

Actually - from what I can see in the log - the repository should be 
registered with RMI:

    24.04.2006 10:19:22 *INFO * RepositoryStartupServlet: Repository
    bound via RMI with name: //localhost:1099/jackrabbit.repository
    (RepositoryStartupServlet.java, line 475)

The log entry for the dump is only informative as the repository startup 
servlet tries to create an RMI registry first and falls back to 
connecting to an existing registry if creation fails. Therefore failure 
to create the registry is not an error. The next entry though is 
actually, what you are looking for: The confirmation, that from the 
point of view of the startup servlet, the repository should be 
registered under the logged URL.

Regards
Felix

Cedric Bosdonnat schrieb:
> Hi Felix,
>
> Thank you for your quick answer :)
>
> Felix Meschberger a écrit :
>
>   
>>>  Some questions to check what I might do wrong:
>>>    + What is the default port used for RMI ?
>>>       
>> The default RMI port in a Java VM is 1099
>>     
>
> That's what I thought...
>
>   
>>>    + is the //localhost/jackrabbit.repository url correct ?
>>>       
>> No, the default configuration would be for port 1099, that is
>> //localhost:1099/jackrabbit.repository
>>     
>
> Ok... thus omitting the port won't choose the default one ? nevermind...
>
>   
>>>    + is there something else to add ?
>>>       
>> Considering, you might not have used the correct port, this might be
>> your issue. Else, I cannot tell without logs.
>>     
>
> I added the logs of the jackrabbit servlet startup here:
> http://pastebin.com/678426
> It seems like the port 1099 is busy... but netstat -a doesn't show me
> this port as active... I even try to change the port, but I still get
> the same exception: "Port already used".
>
> I didn't found them at first look because the log4j line for the file
> appender was commented (default option :().
>
> Thanks for your help,
> Cedric
>   



Mime
View raw message