jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexandru Popescu (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-352) Upgrade to Lucene 1.9.1
Date Fri, 17 Mar 2006 21:15:29 GMT
    [ http://issues.apache.org/jira/browse/JCR-352?page=comments#action_12370884 ] 

Alexandru Popescu commented on JCR-352:
---------------------------------------

I have followed the recommendation from Lucene ML and I have compiled Jackrabbit branch 1.0
code (384322) against the Lucene 1.9.1 distribution. 
There is an incompatibility but a really small one than can be patched right away:

org.apache.jackrabbit.core.query.lucene.WildcardTermEnum.difference(): the method is current
protected, but in Lucene 1.9.1 FilteredTermEnum it is declared as public abstract.

So, if Jackrabbit 1.0 wants to be compatible with both Lucene versions it just needs to make
this small change.

Do you think this would be possible for the 1.0rc2? (I guess there is no issue having such
a small change).

./alex
--
.w( the_mindstorm )p.


> Upgrade to Lucene 1.9.1
> -----------------------
>
>          Key: JCR-352
>          URL: http://issues.apache.org/jira/browse/JCR-352
>      Project: Jackrabbit
>         Type: Improvement
>     Versions: 1.1, 1.0.1, 1.0
>  Environment: All
>     Reporter: Michael Young
>     Assignee: Jukka Zitting

>
> We would like to upgrade to Lucene 1.9.1. There are jar conflicts when integrating with
other projects such as Liferay Portal --  which uses v 1.9.1.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message