jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-352) Upgrade to Lucene 1.9.1
Date Sun, 19 Mar 2006 22:11:00 GMT
    [ http://issues.apache.org/jira/browse/JCR-352?page=comments#action_12371017 ] 

Jukka Zitting commented on JCR-352:
-----------------------------------

> quote: "When you call FSDirectory.openFile(String) you get a ClassCastException since
FSIndexInput is not an
> org.apache.lucene.store.InputStream The workaround is to reimplement using openInput(String)."


I think the openInput() method is only available since Lucene 1.9, so we can't use this workaround
as long as we want to keep compatibility with Lucene 1.4.

PS. Here's the Lucene issue link without the embedded "watch this issue" action: http://issues.apache.org/jira/browse/LUCENE-523
:-) 

> Upgrade to Lucene 1.9.1
> -----------------------
>
>          Key: JCR-352
>          URL: http://issues.apache.org/jira/browse/JCR-352
>      Project: Jackrabbit
>         Type: Improvement
>     Versions: 1.0, 0.9
>  Environment: All
>     Reporter: Michael Young
>     Assignee: Jukka Zitting

>
> We would like to upgrade to Lucene 1.9.1. There are jar conflicts when integrating with
other projects such as Liferay Portal --  which uses v 1.9.1.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message