jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Pfister <dominique.pfis...@day.com>
Subject Re: Beginners JTA question-problems with clone when using container
Date Tue, 14 Feb 2006 09:28:32 GMT
Hi Giota,

Following your description, I wrote a simple test case and added it to
my local XATest class contained in the org.apache.jackrabbit.core
package:

   /**
    * Test cloning a node and setting its properties.
    */
   public void testCloneNode() throws Exception {
       // add a new node to the "test" workspace
       Session testSuperuser = helper.getSuperuserSession("test");
       Node otherRoot = testSuperuser.getRootNode();
       Node otherNode = otherRoot.addNode("a");
       otherRoot.save();

       // get user transaction object
       UserTransaction utx = new UserTransactionImpl(superuser);

       // start transaction
       utx.begin();

       // clone node from "test" workspace
       superuser.getWorkspace().clone("test",
               otherNode.getPath(), testRoot + "/a", true);
       Node cloned = (Node) superuser.getItem(testRoot + "/a");
       // set some properties on cloned node
       cloned.setProperty("originalPath", otherNode.getPath());
       cloned.setProperty("originalWorkspace",
               otherNode.getSession().getWorkspace().getName());
       cloned.save();
   }

This test case creates a new node in the "test" workspace and then
clones it to the "default" workspace. It runs without problems and the
new node gets visible to other sessions on the same workspace only
after commit, as expected. Of course, it uses the "dummy"
UserTransaction object and is therefore possibly not as representative
as an appserver environment.

Could you tell me, whether this test case reflects what you are doing?
It could be helpful, if you would supply information about your
environment (OS/Appserver/JVM) too...

Regards
Dominique

On 2/10/06, Giota Karadimitriou <Giota.Karadimitriou@eurodyn.com> wrote:
>
>
> I know I bring up an old thread but I would like to share some problems
> I encountered lately, related to jackrabbit and transactions when using
> a container.
>
> After Dominique's excellent suggestion to make jackrabbit a resource
> adapter (thanks again Dominique!), things worked ok for me for a while.
>
> However I recently ran into some new problems. The scenario I wanted to
> perform is the following,
>
> 1. I move a node from one workspace to another using clone
>
> wsDest.clone(originalWorkspace, originalPath,
>                   name, true);
>
> 2. And then I want to set 2 of its properties, namely originalPath and
> originalWorkspace.
>
> ...
> Node rn = session.getRootNode();
> log.debug("rn=" + rn);
> Node movedNode = rn.getNode(name);
> log.debug("movedNode=" + movedNode);
> movedNode.setProperty("originalPath",originalPath); !!!!HERE EXCEPTION
> movedNode.setProperty("originalWorkspace",originalWorkspace);
> session.save();
>
> The problem I encountered was that an 'ItemNotFound exception' happens
> in this step when I call setProperty, even though the moved node is
> succefully printed in the previous step.
>
> This happens probably because now that jackrabbit is transactional, the
> 'move' only takes place virtually and not physically until the end of
> the transaction, thus preventing jackrabbit from really locating the
> node when trying to setProperty.
>
> However, the question is should jackrabbit throw such an exception since
> the 'move' changes are not yet persisted? Is there a way to check
> persistency and not to try to locate sth that is not yet persisted?
>
> If I try to set the properties on the original node before moving it,
> it's 'clone' itself that fails.
>
> Finally I tried as a final step to create a new node in the other
> workspace and copy all the properties of the old one into the new, then
> remove the old
> and save both sessions (new and old) but then I get a 'Two phase commit
> failed' error.
>
> regards
> Giota
>
> -----Original Message-----
> From: dominique.pfister@gmail.com [mailto:dominique.pfister@gmail.com]
> On Behalf Of Dominique Pfister
> Sent: Thursday, January 12, 2006 9:43 AM
> To: jackrabbit-dev@incubator.apache.org
> Subject: Re: Beginners JTA question
>
> Hi Kevin,
>
> The UserTransactionImpl in Jackrabbit is used solely for testing
> purposes, where you usually don't have an application server within
> reach, sorry, if this is confusing.
>
> In order to make Jackrabbit work as an XA resource, you have to make
> it available as a resource adapter (RA) in your application server.
> There is a contribution named jca in the contrib directory that
> packages jackrabbit into a deployable RAR (resource adapter archive).
>
> For BEA, you'll probably want to add a weblogic-ra.xml to the RAR's
> META-INF folder that specifies the JNDI name where your RA will be
> made available to applications. Finally, your web application will
> need a resource-ref entry that has to be linked to the RA's JNDI name.
> If you then reference this resource in your code:
>
> Repository rep = (Repository) new
> InitialContext().lookup("java:comp/env/jackrabbit");
>
> it will automatically be enlisted as an XAResource in BEA's
> UserTransaction.
>
> Cheers
> Dominique
>
> On 1/11/06, Kevin Wiggen <kwiggen@xythos.com> wrote:
> > Sorry if this question is a newbie to JTA question, but I have been
> > looking at the jackrabbit code and I can't figure the following out.
> >
> >
> >
> > I want to use Jackrabbit in my BEA container and use JTA to coordinate
> > the transaction with Jackrabbit and my other JTA transactional
> > resources.  The other resources already are plugged into the BEA world
> > and code uses the BEA UserTransaction to coordinate the interaction
> > between these resources.
> >
> >
> >
> > The short question is how do I wire up Jackrabbit to work in this
> world?
> >
> >
> >
> > From what I see (and I can be completely looking in the wrong spot),
> > Jackrabbit uses XASessionImpl to appear as a XAResource, and I see in
> > XATest how the Jackrabbit UserTransactionImpl is used to get a
> > Jackrabbit specific UserTransaction, but I already have my own
> > UserTransaction (well BEA's).
> >
> >
> >
> > Am I missing something obvious?  I just don't see how I can get
> > Jackrabbit to play in my UserTransaction world....
> >
> >
> >
> > Thanks for the help,
> >
> > Kevin
> >
> >
> >
>
>
>

Mime
View raw message