jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Slater <li...@humanesoftware.com>
Subject Re: Model-2 Deployment example and test app
Date Tue, 14 Feb 2006 03:29:48 GMT
Another update. I added the log4j.properties to tomcat and am now  
able to watch it initialize the repository; there are no errors  
during the process. Unfortunately, none of the jackrabbit code seems  
to be executed when I try to get the BindableRepository from the  
context. I'm assuming at this point its a Tomcat configuration issue,  
because I've tried a fair number of configurations (embedded-model-1,  
shared-model-2, both, defined in global context, defined in local  
context, defined in server.xml, etc.) and am no closer to a solution.  
I've posted to the Tomcat's users for help, but if anyone here has a  
spare cycle to point me in the right direction, I'd really appreciate  

In the most recent trial (embedded repository defined in servlet.xml)  
I'm able to get an Integer value stored in the context, but when I  
try to get the jackrabbit repository, I get a class not found  
exception on BindableRepositoryFactory. This is despite having the  
jackrabbit jar file in both the webapp's WEB-INF/lib/ and Tomcat's  


On Feb 13, 2006, at 8:15 AM, Mark Slater wrote:

> Nope. There's no errors in any of the log files. I tried moving  
> Jackrabbit jar files (and dependencies) to server/lib (they had all  
> been in common/lib) leaving only jcr-1.0.jar in common/lib ...  
> restarted Tomcat ... no change in results.
> I know Jackrabbit is being initialized because, over the weekend,  
> as soon as I'd put all the dependencies into common/lib I stopped  
> getting exceptions during Tomcat's initialization and the  
> repository got initialized (the local file system and the database  
> tables). That's when I started writing the servlet.
> The only mention of Jackrabbit in the catalina.out file is at the  
> very start of Tomcat's initialization, I get these lines:
> log4j:WARN No appenders could be found for logger  
> (org.apache.jackrabbit.core.fs.local.LocalFileSystem).
> log4j:WARN Please initialize the log4j system properly.
> I'd worry about the log4j configuration but the exception doesn't  
> show any Jackrabbit code in the stack... its mostly tomcat,  
> catalina, and naming packages, with a few calls to java/javax code  
> and my doGet() servlet function.
> Mark
> On Feb 13, 2006, at 2:04 AM, Jukka Zitting wrote:
>> Hi,
>> On 2/13/06, Mark Slater <lists@humanesoftware.com> wrote:
>>> However, when I run my servlet, I get:
>>> javax.naming.NamingException: Cannot create resource instance
>> Do you have some errors showing up in the Tomcat error log? One
>> possible cause for this problem is that you don't have the Jackrabbit
>> jar files in the correct place. A safe alternative is to just put all
>> the jars in common/lib, but a more correct way would be to put only
>> the jcr-1.0.jar in the common class loader and the Jackrabbit jar  
>> file
>> (and the dependencies) in the server class loader.
>> BR,
>> Jukka Zitting
>> --
>> Yukatan - http://yukatan.fi/ - info@yukatan.fi
>> Software craftmanship, JCR consulting, and Java development

View raw message