jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Perez <mper...@gmail.com>
Subject Re: Shock. Simple queries don't run with current build.
Date Mon, 09 Jan 2006 17:16:34 GMT
:-(

That explains everything. The info that I was looking was under jcr:system.
The fact is that if I did a //* search and then check
node.isNodeType("my:type"),
I could find what I was looking for, but doing //element(*,my:type) directly
did not return nothing.

Where can I find information about that system query handler?

On 1/9/06, Marcel Reutegger <marcel.reutegger@gmx.net> wrote:
>
> Hi Martin,
>
> I just tried all your queries and they worked well on the current svn
> checkout.
>
> There was a recent change in the query code to separate the workspace
> index from the system index [1] and [2]. Did you try your test with the
> new configuration using a system query handler?
>
> regards
>   marcel
>
> [1] http://issues.apache.org/jira/browse/JCR-257
> [2] http://thread.gmane.org/gmane.comp.apache.jackrabbit.devel/4057
>
> Martin Perez wrote:
> > Well, I'm really shocked!
> >
> > Just now I downloaded jackrabbit SVN sources trying to solve the problem
> I
> > explained in my last email. Well, now, I have lost 4 hours more with
> another
> > bug related with the current project SVN state.
> >
> > Could some explain me why this **simple queries**:
> >
> > //element(*,my:type)
> > //element(*,my:type)[@my:property='foo']
> > //*[@jcr:primaryType='my:type' and @my:property='foo']
> >
> > work fine and return results with a version from a month ago and **DO
> NOT
> > WORK** (do not return results) with the current SVN version.
> >
> > Sorry for the tone, but I really have lost a lot of time today :(
> >
> > Martin
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message