jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jukka Zitting <jukka.zitt...@gmail.com>
Subject Re: A beginner question
Date Thu, 05 Jan 2006 13:47:11 GMT
Hi,

On 1/5/06, sirène vip <sirene_vip@hotmail.com> wrote:
> 1. I cannot find "jackrabbit-commons-1.0-dev.jar",
> "jackrabbit-api-1.0-dev.jar" and "jackrabbit-core-1.0-dev.jar" in target/lib
> as mentioned in First Hops example.

The example is unfortunately out of date, the Jackrabbit build system
underwent a few changes during last summer and nobody noticed to
update the First Hops page to reflect that. Thanks for pointing the
problem out!

> However, I have in $HOME_Directory\.maven\repository,
> jackrabbit-commons-1.0-SNAPSHOT and jackrabbit-1.0-SNAPSHOT thanks to maven
> jar:install.

The jackrabbit-1.0-SNAPSHOT.jar is the one you need. The
jackrabbit-commons jar contains a subset of the classes in the main
jackrabbit jar and is used as a source of common functionality for
other JCR applications.

> 2. I included in a lib folder all the dependencies required for Jackrabbit
> as well as the above jars. Still it cannot find the pakage
> org.apache.jackrabbit.core.jndi.

The o.a.j.core.jndi package should be included in the
jackrabbit-1.0-SNAPSHOT.jar. Are you sure your classpath includes the
correct jar files?

BR,

Jukka Zitting

--
Yukatan - http://yukatan.fi/ - info@yukatan.fi
Software craftmanship, JCR consulting, and Java development
Mime
View raw message