jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From solprovi...@apache.org
Subject Re: Maven downloads wrong version of commons-collections
Date Sun, 04 Dec 2005 20:26:39 GMT
On 12/4/05, Stefan Guggisberg <stefan.guggisberg@gmail.com> wrote:
> On 12/4/05, solprovider@apache.org <solprovider@apache.org> wrote:
> > Maven downloaded commons-collections-2.1.jar when it needs
> > commons-collections-3.1.jar.
>
> ??? i seriously doubt that! have a look at jackrabbit/project.xml:
>         <dependency>
>             <groupId>commons-collections</groupId>
>             <artifactId>commons-collections</artifactId>
>             <version>3.1</version>
>         </dependency>

I looked.  You are correct.

svn jackrabbit
installed Maven1.0.2
maven clean
maven

tested example

compile required CLASSPATH =
jackrabbit-1.0-SNAPSHOT.jar
jcr-1.0.jar

running required CLASSPATH =  (Source of file)
jackrabbit-1.0-SNAPSHOT.jar (Jackrabbit)
jcr-1.0.jar (Maven)
commons-collections-3.1.jar  (Downloaded because Maven had wrong version)
log4j-1.2.8.jar (Maven)
xerces-2.4.0.jar (Maven)
xml-apis-1.0.b2.jar (Maven)
lucene-1.4.1.jar (Lenya)

Most of them were in Maven's lib directory.  Is there a JAR containing
everything Jackrabbit needs?  Are these files downloaded somewhere for
Jackrabbit's use?  It feels like I did too much work, but Jackrabbit
runs.

solprovider

Mime
View raw message