jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Darton" <pet...@intrinsica.co.uk>
Subject RE: FW: JCR, RMI & WebDAV - draft HOWTO
Date Thu, 08 Dec 2005 16:56:58 GMT
Toby wrote:
> just a few notes:
> - you have much less hassle, if you are using jdk1.4.2 (no 
> xalan issues)

Thanks.
If/when I write "version 2", I'll make sure this gets mentioned.
Unfortunately, I rather like Generics (the need to cast everything when
using the standard collection classes was, I believe, Java's main
weakness) so I'm using Java 5 for everything here.


> - log4j should be initialized properly, if you are using the 
> LoggingServlet

I was.  At least, I hadn't disabled it in any way.

I get the following error:
log4j:WARN No appenders could be found for logger
(org.apache.jackrabbit.j2ee.RepositoryStartupServlet).

That servlet code doesn't extend the logging servlet and didn't use its
logger, hence exceptions it reports don't appear (which means debugging
why a repository fails to start is more difficult than it needs to be)


> - the default goal in the 'jackrabbit' directory should 
> actually build & test it completely
> - the default goal in the 'jcr-server' contrib, should 
> actually build all jcr-server jars

I can't remember where I got the instructions from (but I assure you I
did little more than google for them...), but the instructions for
building the jcr-server code that I followed made no mention of the
parent target.
I do remember that I tried to do this first, but it failed.
Unfortunately, I didn't make a note of the error, and can't remember how
it failed.

So, I've just done a "clean" of everything, including maven's hidden
directory, and rebuilt.
If I do:
  cd jackrabbit
  maven
  cd ../contrib/jcr-rmi
  maven
  cd ../jcr-server
  maven
Then the first build takes about 15 minutes, but the second (building
jcr-rmi) only takes 6 seconds and doesn't appear to do anything much.
The third build (of jcr-server) then fails with an unsatisfied
dependency:
...
Attempting to download jackrabbit-commons-1.0-SNAPSHOT.jar.
WARNING: Failed to download jackrabbit-commons-1.0-SNAPSHOT.jar.

BUILD FAILED
File......
/home/INL/peterd/.maven/cache/maven-multiproject-plugin-1.3.1/plugin.jel
ly
Element... maven:reactor
Line...... 217
Column.... 9
The build cannot continue because of the following unsatisfied
dependency:

jackrabbit-commons-1.0-SNAPSHOT.jar

Total time: 8 seconds
Finished at: Thu Dec 08 11:06:51 GMT 2005

I find that it is necessary to give "jcr-rmi" a real target to build (I
used "jar:install"), otherwise it doesn't build anything, and in
addition, unless one tells jackrabbit to build "jar:install", all the
contrib code fails because jackrabbit isn't known to maven.

So, whilst I admit that it turns that there's a simpler way to build the
"jcr-server" code than I documented, the default targets on "jackrabbit"
itself and "jcr-rmi" really aren't beginner-friendly.


> - the repository can be bind to the RMI registry, using the 
> respective settings in the init-params of the 
> RepositoryStartupServlet (web.xml).
> just uncomment the RMI section

I'm aware that the configuration file implies that this is possible.
I haven't had much success getting it to do so, however - I get the
repository registered in RMI, but attempts to access it fail with a
marshalling error.
That's why I ended up writing a separate "daemon" process instead - that
worked just fine.


> > Q1) Why on earth wasn't JCR designed with remote access in mind?
> it totaly is!
Yup, I missed the client RMI code completely.
See
http://www.mail-archive.com/jackrabbit-dev%40incubator.apache.org/msg037
92.html for the embarassing details.


> > Q4) Developing outside of maven
> just use:
> > maven idea
> or
> > maven eclipse
> or
> > maven netbeans
> 
> to build your projects

If I try (on any of the projects I'm interested in):
> maven netbeans
I get told:
/opt/maven-1.0.2/bin/maven netbeans
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0.2

BUILD FAILED
Goal "netbeans" does not exist in this project.
Total time: 5 seconds
Finished at: Thu Dec 08 10:49:27 GMT 2005

Furthermore, if I do /opt/maven-1.0.2/bin/maven --goals then netbeans is
entirely absent from the list.  I can see that idea and eclipse are
there, just not netbeans (which is the IDE I'm used to, and the IDE my
boss told me to use).  Hence I concluded that netbeans wasn't supported.

However, I've since done a bit of googling, and I've found
http://mevenide.codehaus.org/index.html - do you know if this is what
I'd need to get the "netbeans" target available?
How did you get the "netbeans" target?
Was it "always there" or did you do something to make it available?
If so, what did you do?

Thanks,

  Peter

_____________________________________________________________________
This e-mail has been scanned for viruses by MCI's Internet Managed Scanning Services - powered
by MessageLabs. For further information visit http://www.mci.com

Mime
View raw message