jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonis Tsaltas <Antonis.Tsal...@eurodyn.com>
Subject Can oracle be used with jackrabbit?
Date Thu, 15 Dec 2005 12:35:50 GMT
Dear all,

I am trying to use oracle with jackrabbit and the steps I have followed 
are the following:

1) I have created the ddl files needed for creating the schemas with 
oracle database similar to the existing ones and add them to the 
appropriate package in the jackrabbit jar generated after the build. 
However, when I tried to run a sample application I got nested 
exceptions during the configuration of the repository and more specific 
during the insertion of the root node due to the case that Oracle is 
treating an emptry string and null as the same and the fsname of the 
root node is empty string.

2) Next I tried to allow nullable values for the fsname as this will 
only be the case for the root node and there will be no manual updates 
to the repository. At this point it failed again when it tried to add an 
entry '/meta' in fsentries table when it was checking if the parent of 
this node exists (which is root node '/' ). There it performs the 
following query:

select 1 from REP_FSENTRY where FSENTRY_PATH = '/' and
FSENTRY_NAME is null

which is in oracle equivalent with this:

select 1 from REP_FSENTRY where FSENTRY_PATH = '/' and
FSENTRY_NAME=''

and then it tries to insert the root node again but there is the logical 
constraint:

create unique index ${schemaObjectPrefix}FSENTRY_IDX on 
${schemaObjectPrefix}FSENTRY
  (FSENTRY_PATH, FSENTRY_NAME).

Are there any suggestion or does anyone know if jackrabbit can work fine 
with oracle db server?

Thanx

Mime
View raw message