jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Darton (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-289) jcr-server: webdav servlet does not read authenticate-header parameter
Date Thu, 08 Dec 2005 17:11:09 GMT
    [ http://issues.apache.org/jira/browse/JCR-289?page=comments#action_12359749 ] 

Peter Darton commented on JCR-289:

Hmm "publish and be damned" they say...
It seems my asserion is not 100% correct.
The section _does_ get read and acted upon when accessing .../jackrabbit-server/repository/
but has NO EFFECT on .../jackrabbit-server/server/
This might well be "working as designed".

I suspect, therefore, that the code is working as designed.

However, it would be nice if it were possible to set the "authenticate-header" on the JCRWebdavServer
servlet as well (and for the configuration to be present, but commented out, in web.xml),
just like the Webdav servlet.

> jcr-server: webdav servlet does not read authenticate-header parameter
> ----------------------------------------------------------------------
>          Key: JCR-289
>          URL: http://issues.apache.org/jira/browse/JCR-289
>      Project: Jackrabbit
>         Type: Bug
>     Reporter: Peter Darton
>     Priority: Trivial

> In WEB-INF/web.xml, there is a section (commented-out by default) that reads:
>         <init-param>
>             <param-name>authenticate-header</param-name>
>             <param-value>Basic realm="Jackrabbit Webdav Server"</param-value>
>             <description>
>                 Defines the value of the 'WWW-Authenticate' header.
>             </description>
>         </init-param>
> This parameter is ignored (not loaded) by the code - the default string is always used
> Note: this was more of a problem before JCR-286 had been fixed

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message