jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jukka Zitting <ju...@zitting.name>
Subject Re: [jackrabbit] Maven build error
Date Thu, 10 Nov 2005 10:00:10 GMT
Hi,

Humer G√ľnther wrote:
> But it doesn't succeed in this directory neither. Now I get followin error:
> 
> ...
>     [xslt] Loading stylesheet D:\Development\vendor\jackrabbit\jackrabbit\jackra
> bbit\src\main\javacc\xpath\strip.xsl
> 
> BUILD FAILED
> File...... D:\Development\vendor\jackrabbit\jackrabbit\jackrabbit\maven.xml
> Element... ant:xslt
> Line...... 142
> Column.... 25
> org/apache/xml/serializer/SerializerTrace

As Alexandru Popescu already mentioned, this seems like a Java 5 issue.
I suppose you noticed the mention about xalan.jar being needed when
building with JDK 1.5. Since version 2.7 Xalan-Java has split some of
the classes from xalan.jar into serializer.jar, and that library is now
needed as well. I just finally committed a mention of this into
README.txt. The full notice is:

  NOTE: Java 5 users need to download the xalan.jar and serializer.jar
  libraries from the Xalan-Java binary distribution at
  http://xml.apache.org/xalan-j/downloads.html and place them in
  $MAVEN_HOME/lib/endorsed (or $JRE/lib/endorsed if using Maven 1.1)
  to build the Jackrabbit sources. The reason for this workaround is
  explained in

     http://issues.apache.org/jira/browse/JCR-46

I hope this helps!

BR,

Jukka Zitting


Mime
View raw message