jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Melis" <steven.me...@student.kuleuven.be>
Subject Re: javax.jcr.ItemNotFoundException:16a12c02-fb63-4f82-a210-fa54c9421d59
Date Wed, 26 Oct 2005 13:31:48 GMT
Hi,

I also work with an eclipse plugin from day who visualizes the content of
 your JCR.  You can also add a node through this interface, which I used to
 do frequently in the past.  When I add a node this way now, I get the same
 exception as when I run my program in eclipse.  I attached 2 snapshots of
 this plugin to illustrate my problem.  I really don't understand why I get
 this exception if I'm trying to add a node.

 I wanted to start from scratch again so, today I have uninstalled my Tomcat
 application server and reinstalled it.  Then I've redeployed jackrabbit.war
 on the server and reconfigurated my repository.xml and web.xml file.  And
 again when I add a node I get this exception.  Can anyone help me?

 Kind regards,
Steven Melis


 >----- Original Message ----- 
> From: "Jukka Zitting" <jukka@zitting.name>
> To: <jackrabbit-dev@incubator.apache.org>
> Sent: Tuesday, October 25, 2005 6:44 PM
> Subject: Re:
> javax.jcr.ItemNotFoundException:16a12c02-fb63-4f82-a210-fa54c9421d59
>
>
>> Hi,
>>
>> This seems very much like a source vs. bytecode mismatch issue. Steven,
>> are you
>> sure you are using the class files compiled from your latest sources? It
>> is not
>> possible for the last two lines of the stack trace to originate from the
>> code
>> you pasted.
>>
>> [Copy of a previous message sent directly to Steven:]
>>
>> Steven Mellis wrote:
>>> I pasted the code below, which always worked untill recently
>>> (I also pasted the stacktrace). All I want to do is add a node to the
>>> root node of my repository and even then I get this
>>> ItemNotFoundException... Can Anyone help my with my problem?
>>
>> Are you sure the problem is caused by the code you pasted? There is no
>> Session.getNodeByUUID() call there, but look at the tail of the stack
>> trace:
>>
>>> javax.jcr.ItemNotFoundException: 16a12c02-fb63-4f82-a210-fa54c9421d59
>>> [...]
>>> at
>>> org.apache.jackrabbit.rmi.client.ClientSession.getNodeByUUID(ClientSession.java:172)
>>> at
>>> com.alcatel.rena.pubsub.jcr.JCRInitializer.main(JCRInitializer.java:74)
>>
>> You might want to check line 74 of JCRInitializer.java. At least 
>> according
>> to
>> this stack trace it contains a Session.getNodeByUUID() call. The given
>> UUID
>> doesn't seem to exists, so the repository throws an 
>> ItemNotFoundException.
>>
>> BR,
>>
>> Jukka Zitting
>>
> 

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message