jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Newton" <john.new...@alfresco.org>
Subject RE: Bug in NodeReadMethodsTest.java?
Date Thu, 15 Sep 2005 15:52:50 GMT

The appeals process suggests sending the appeal to the maintainer of the TCK. The maintainer
is also supposed to be responsible for interpretations.

Who is the maintainer? We thought it was Jackrabbit. Is it Day? Is it a specific person?

TIA for your help

John Newton
Alfresco.org
Top Floor, Park House, Park Street
Maidenhead, Berks SL6 1SL
United Kingdom
Click here for map
+44 7890 270 532 (M)
+44 1628 860 500 (P)
+44 1628 860 501 (F)
+44 1628 860 639 (D)
mailto:john.newton@alfresco.org



> -----Original Message-----
> From: Marcel Reutegger [mailto:marcel.reutegger@gmx.net]
> Sent: 15 September 2005 01:23
> To: jackrabbit-dev@incubator.apache.org
> Subject: Re: Bug in NodeReadMethodsTest.java?
> 
> Hi David,
> 
> thanks for reporting this issue, this is clearly a bug in the test code.
> 
> I've fixed it as you suggested (svn revision: 289176)
> 
>  > I assume this is the place to report this kind of problem.
> 
> yes it is, though if you feel a test case should be exclude from the
> official TCK (1.0) because it poses a problem for your implementation,
> you should follow the appeals process as defined by the JCP. We just
> host the test code here in jackrabbit.
> 
> regards
>   marcel
> 
> David Caruana wrote:
> > The testGetIndex() test searches for a node with same name siblings
> > somewhere in the repository. It seems it will only find that node, if:
> >
> > 1) The node is the one identified by the test config value
> > javax.jcr.tck.NodeReadMethodsTest.testroot
> > 2) Its first child is one of the same name siblings
> >
> > It's possible that people may be mislead in that they believe the test
> > has passed, but in fact, their same name siblings were never found.
> >
> > The method locateNodeWithSameNameSiblings(Node node) within
> > NodeReadMethodsTest.java looks like the culprit:
> >
> > 1011          } else {
> > 1012              Node returnedNode = locateNodeWithSameNameSiblings(n);
> > 1013              if (n != null) {
> > 1014                 return returnedNode;
> > 1015              }
> > 1016           }
> >
> > line 1013 should be if (returnedNode != null) {
> >
> > Changing to the above has allowed me to execute the test without messing
> > around with my test data.
> >
> > I assume this is the place to report this kind of problem.
> >
> > Regards,
> > David Caruana
> > www.alfresco.org
> >
> >

Mime
View raw message