jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Guggisberg (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (JCR-133) Problem with '<' character in node names and (probably) XMLPersistenceManager
Date Sun, 12 Jun 2005 08:43:49 GMT
     [ http://issues.apache.org/jira/browse/JCR-133?page=all ]

Stefan Guggisberg reassigned JCR-133:
-------------------------------------

    Assign To: Stefan Guggisberg

> Problem with '<' character in node names and (probably) XMLPersistenceManager
> -----------------------------------------------------------------------------
>
>          Key: JCR-133
>          URL: http://issues.apache.org/jira/browse/JCR-133
>      Project: Jackrabbit
>         Type: Bug
>     Reporter: C├ędric Damioli
>     Assignee: Stefan Guggisberg

>
> I'm using the XMLPersistenceManager.
> Node.addNode() permits to have the '<' character in the addes node name.
> This node is even successfully created.
> But after shutdown, the repository can't restart anymore, as the XML contained in the
.node.xml is malformed.
> The Lucene index failed to initialize with an error such as "Invalid character in node
name : '<'"
> After patching the XML file by hand, the repository normally retstart.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message