jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jessica Delsinne" <jessica.delsi...@bull.net>
Subject Re: jcr-rmi.jar construction problem
Date Mon, 27 Jun 2005 13:48:55 GMT
thank you for your help.

I have now another problem :
.
At step 2 (Context configuration), I have to add the following snippet in
server.xml, under the
context element.
<Resource name="jcr/repository"
              auth="Container"
              type="javax.jcr.Repository"/>
<ResourceParams.........
</ResourceParams>

The problem is that in the file server.xml, I have no context element. (I
use Tomcat 5.0.30, integrated to JOnAS 4.3.4).
I tryed to create myself a context element inside the  <Host> element, like
that :
<Host>
.....
<Context>
<Resource name="jcr/repository"
              auth="Container"
              type="javax.jcr.Repository"/>
<ResourceParams.........
</ResourceParams>
</Context>
</Host>

But it does not work. I have thos error when I want to start JOnAS :

2005-06-27 15:43:50,552 : ServerLifecycleListener.createMBeans :
createMBeans: Throwable
java.lang.NullPointerException
        at
org.apache.catalina.mbeans.MBeanUtils.createObjectName(MBeanUtils.java:1307)
        at
org.apache.catalina.mbeans.MBeanUtils.createMBean(MBeanUtils.java:581)
        at
org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(ServerLifecy
cleList
ener.java:689)
        at
org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(ServerLifecy
cleList

Can you help me how I have to create this context element ?

Thank you,
Jessica

----- Original Message -----
From: "Felix Meschberger" <Felix.Meschberger@day.com>
To: <jackrabbit-dev@incubator.apache.org>
Sent: Friday, June 24, 2005 5:42 PM
Subject: Re: jcr-rmi.jar construction problem


> Hi Jessica,
>
> The JUnit Testcases for the project most probably are not up to date.
> You may come by by disabling the tests with
>
>    $ maven -D maven.test.skip=true jar
>
> Regards
> Felix
>
> Jessica Delsinne schrieb:
>
> >Hi,
> >I am trying to build the jcr-rmi.jar file because I would like to use a
Jackrabbit content repository in the deployment model 3 : The Repository
Server.
> >
> >When I run the command line "maven", I had no problem.
> >And the, when I run "maven jar", I had this error :
> >
> >test:test:
> >    [junit] Running org.apache.jackrabbit.test.rmi.RemoteAdapterTest
> >    [junit] Tests run: 19, Failures: 0, Errors: 2, Time elapsed: 2,804
sec
> >    [junit] [ERROR] Test org.apache.jackrabbit.test.rmi.RemoteAdapterTest
FAILED
> >
> >LA CONSTRUCTION A ?CHOU?
> >Fichier... C:\Documents and
Settings\delsinnj\.maven\cache\maven-test-plugin-1.6
> >y
> >?lement... fail
> >Ligne..... 181
> >Colonne... -1
> >There were test failures.
> >Temps total    : 9 minutes 17 secondes
> >Fini le        : vendredi 24 juin 2005 16:40:46 CEST
> >
> >Do you know what is the problem ?
> >Thank you,
> >Jessica
> >
> >
>


Mime
View raw message