jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gennady Azarenkov <gazaren...@gmail.com>
Subject Re: Test data for TCK
Date Fri, 03 Jun 2005 07:32:51 GMT
Hi,

I am testing on Windows.

That is what i changed in repositoryStubImpl.properties:
javax.jcr.tck.repository_stub_impl=org.exoplatform.services.jcr.ExoRepositoryStub
# credential configuration
javax.jcr.tck.superuser.name=exo
javax.jcr.tck.superuser.pwd=exo
javax.jcr.tck.readwrite.name=exo
javax.jcr.tck.readwrite.pwd=exo
javax.jcr.tck.readonly.name=exo
javax.jcr.tck.readonly.pwd=exo

The repository seems to be empty for read-only tests, when i tried to fill 
it adding the code to AbstractJCRTest it works
but i am not sure if the data is correct.
I guess there should be some procedure for inserting the test data for r/o 
tests but how to turn it on that is the question. :)

Thanks,

Gennady Azarenkov

eXo platform

----- Original Message ----- 
From: "McComsey, Doug" <Doug.Mccomsey@ca.com>
To: <jackrabbit-dev@incubator.apache.org>
Sent: Thursday, June 02, 2005 10:34 PM
Subject: RE: Test data for TCK


I got the same message when I modified this property:
    javax.jcr.tck.testroot
in this file:

contrib\tck-webapp\src\webapp\WEB-INF\classes\repositoryStubImpl.propert
ies

I wanted to use a different folder name for the tests. I resolved it by
changing all instances of "/testroot" to the new name.

If you haven't modified the properties file, ignore this message.

Regards,
Doug McComsey

-----Original Message-----
From: Jukka Zitting [mailto:jukka@zitting.name]
Sent: Thursday, June 02, 2005 1:28 PM
To: jackrabbit-dev@incubator.apache.org
Subject: Re: Test data for TCK

Hi,

Gennady Azarenkov wrote:
> I tried to test our JCR impl with the Jackrabbit's TCK (SVN rev
179569)
> but there are some problems, most of them in read-only tests,
> like: "Workspace does not contain test data at: ..."

Sounds familiar... Are you running the tests on Linux? You might be
experiencing the same problem as I reported in
http://issues.apache.org/jira/browse/JCR-117.

BR,

Jukka Zitting





Mime
View raw message