jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Reutegger (JIRA)" <j...@apache.org>
Subject [jira] Created: (JCR-110) Rename package core.search to core.query
Date Fri, 15 Apr 2005 09:55:28 GMT
Rename package core.search to core.query

         Key: JCR-110
         URL: http://issues.apache.org/jira/browse/JCR-110
     Project: Jackrabbit
        Type: Task
  Components: query  
 Environment: svn revision: 161425
    Reporter: Marcel Reutegger
 Assigned to: Marcel Reutegger 
    Priority: Minor

The package org.apache.jackrabbit.core.search should be renamed to org.apache.jackrabbit.core.query
for consistency with the JCR api. All other packages in Jackrabbit already use the package
names as suggested by the JCR api (javax.jcr.<subpackage>).

If there are other implementations than the Jackrabbit one of the org.apache.jackrabbit.core.search.QueryHandler
interface they need to be adapted to use the new package name!

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
If you want more information on JIRA, or have a bug to report see:

View raw message