jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Serge Huber <shub...@jahia.com>
Subject Re: jackrabbit-orm tests not running out-of-the-box
Date Fri, 01 Apr 2005 10:13:39 GMT

For those interested I put a patch file with the current status of my 
work on contrib/orm-persistence here :

http://www.jahia.org/~loom/orm-20050401-1204.patch

If there is a better way to submit patches (should I create a JIRA entry 
everytime I update the code ?), please let me know.

Maybe this patch should be applied as without it the tests don't run at 
all, but there are still some issues to be solved.

Regards,
  Serge Huber.

Serge Huber wrote:

>
> I just want to say I already did all this for the 
> contrib/orm-persistence project... I just didn't get to publishing it 
> as I have a few remaining issues with the tests and that I'm trying 
> hard to keep in touch with all the daily CVS changes (which is a not a 
> trivial task sometimes).
>
> Regards,
>  Serge Huber.
>
> Marcel Reutegger wrote:
>
>> Hi Thomas,
>>
>>> Marcel: I tried using the main custom_nodetypes.xml, but now I'm 
>>> getting a
>>> new exception. Haven't had time to dig into it, but perhaps I won't 
>>> have
>>> to with the patch.
>>>
>>> Testcase: testAddNodeCommit(org.apache.jackrabbit.core.XATest):    
>>> Caused an
>>> ERROR
>>> Unable to locate a login configuration
>>> java.lang.SecurityException: Unable to locate a login configuration
>>>     at 
>>> com.sun.security.auth.login.ConfigFile.<init>(ConfigFile.java:97)
>>
>>
>>
>> ah, sorry about this. forgot to mention, that you need to copy the 
>> jaas.config too. you'll find one in trunk/applications/test.
>> Thought you fixed that already...
>>
>> regards
>>  marcel
>>
>
>


Mime
View raw message