jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Serge Huber <shub...@jahia.com>
Subject Re: jackrabbit-orm tests not running out-of-the-box
Date Fri, 01 Apr 2005 07:45:52 GMT

Hi Thomas,

I was working on this, but my regular work has been taking over lately. 
I have a bunch of changes that will correct these problems, but I still 
have a few issues with NodeReferences.

If you need this quickly I could send you a patch of my current status ? 
The tests are running but are not all completing correctly (that's what 
I was working on).

Regards,
  Serge Huber.

Thomas Ferris Nicolaisen wrote:

>Hi list,
>
>Seeming nobody else have had this problem, I wouldn't normally post such a
>newbish post on a dev-list, but as of now there aren't many other places
>to ask.
>
>I'm currently in a school project related to CMS-systems and we're trying
>out some various open-source solutions supporting the project. We think
>that implementing Jackrabbit with Hibernate-persistence would be good step
>forward.
>
>So I'm trying it out, but I can't get the orm-persistence tests working
>out-of-the-box. The main jackrabbit tests work fine, though.
>
>My specs: Windows XP, ~850MHz, 256MB ram (too weak for hsqldb?)
>
>What I do (as figured out from the readme's):
>
>1) Checkout from svn-rep into c:\projects\jackrabbit
>2) Run 'maven jar:install' in the dir above. This takes time, but doesn't
>produce any more error than jackrabbit's maven project report shows.
>3) Change dir to c:\projects\jackrabbit\contrib\orm-persistence
>4) Run 'maven clean'
>5) Run 'maven start.test.server'. Works fine. "Listening for connections ..."
>6) Open a new shell, go to c:\projects\jackrabbit\contrib\orm-persistence
>7) Run 'maven'
>
>This produces nothing but failures with ConfigurationExceptions. The
>orm-persistance goal includes running the normal jackrabbit-tests, which
>have configuration files (repository.xml and workspace.xml) built into the
>source directories
>(c:\projects\jackrabbit\src\test\org\apache\jackrabbit\core\config).
>
>The jackrabbit maven goals include these resource files, but the
>jackrabbit-orm maven goals do not.
>
>8) I modify the orm-persistence project.xml to include the resource files
>in ../../src/test.
>
>Upon doing this I get a new configuration error saying that there is no
>class called org.apache.jackrabbit.test.JackrabbitRepositoryStub.
>
>9) I change the javax.jcr.tck.repository_stub_impl property in
>
>C:\projects\jackrabbit\contrib\orm-persistence\applications\test\repositoryStubImpl.properties
>
>to org.apache.jackrabbit.core.JackrabbitRepositoryStub.
>
>Now I get another error because the security element is missing in
>
>C:\projects\jackrabbit\contrib\orm-persistence\applications\test\repository.xml
>
>10) I add this element into repository.xml:
>
>    <Security appName="Jackrabbit">
>        <AccessManager
>class="org.apache.jackrabbit.core.security.SimpleAccessManager">
>        </AccessManager>
>    </Security>
>
>and so that error disappears.
>
>I am now stuck with one error I can't resolve. See the maven report below:
>
>http://folk.uio.no/thomafni/temp/maven-orm-persistence/junit-report.html
>
>After two days of fiddling, this is as close as I've got to get the
>jackrabbit-orm tests to work. I'm probably on the totally wrong track to
>get this working, so please give me a push in the right direction.
>
>Thanks,
>
>Thomas Ferris Nicolaisen
>
>
>  
>


Mime
View raw message