jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Reutegger (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (JCR-112) add target jvm in maven properties for compilation
Date Fri, 22 Apr 2005 08:17:24 GMT
     [ http://issues.apache.org/jira/browse/JCR-112?page=all ]
     
Marcel Reutegger resolved JCR-112:
----------------------------------

    Resolution: Fixed

Jackrabbit requires Java 1.4 or higher.

Added the property values accordingly.

svn revision: 164191

> add target jvm in maven properties for compilation
> --------------------------------------------------
>
>          Key: JCR-112
>          URL: http://issues.apache.org/jira/browse/JCR-112
>      Project: Jackrabbit
>         Type: Improvement
>   Components: maven
>     Reporter: fabrizio giustina
>     Assignee: Marcel Reutegger
>     Priority: Trivial

>
> actually the compatibility level for sources/binaries is not defined in project.properties,
so if you compile jackrabbit with a 1.5 jdk it will not run on older vm.
> It would be nice to add the following properties to assure that the generated jar will
work on different jvms:
> maven.compile.target=1.4
> maven.compile.source=1.4
> (or 1.3 if you are targetting also java 1.3)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message