jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Severance <c...@umich.edu>
Subject Introduction followed by Dumb, Obvious Developer Question
Date Sun, 06 Feb 2005 20:05:05 GMT
<blah-blah>
Hello to the JackRabbit community.  My name is Charles Severance, the Chief
Architect of the Sakai project - www.sakaiproject.org -
collab.sakaiproject.org has a sample system up and running.

I am kicking the tires on Jackrabbit for possible adoption as the core of
our storage within Sakai (An open source collaboration and learning
management system).  If we were to jump in here with Jackrabbit, we would
probably write/improve/contribute an open source high performance
implementation to scale to 100000 users at a single site (yikes).   We are
already well underway to building a fast, scalable, hierarchical
authorizaion system using Hibernate.

I have 2-3 developers to dedicate to this effort for the next six months if
we adopt Jackrabbit because our alternative is to write this ourselves from
scratch with our own API.
</blah-blah>

I am trying to do a quick test integration over the weekend and almost have
it running - but all my unit tests are failing.  I checked out the code,
upgraded my maven plugin, and ran "maven jar" just like the README says.
Everything compiles fine except the Unit tests all fail with:

[junit] Running org.apache.jackrabbit.test.observation.TestAll
[junit] Exception in thread "main" java.lang.NoClassDefFoundError:
org/w3c/dom/ranges/DocumentRange
[junit]     at java.lang.ClassLoader.defineClass0(Native Method)
[junit]     at java.lang.ClassLoader.defineClass(ClassLoader.java:539)

[snip]

[junit]     at 
org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestR
unner.java:536)
[junit] [ERROR] TEST org.apache.jackrabbit.test.search.TestAll FAILED

I am betting that this has a really simple solution :)

Thanks in advance.

Charles Severance
www.dr-chuck.com
csev@umich.edu



Mime
View raw message