jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-46) Provider org.apache.xalan.processor.TransformerFactoryImpl not found
Date Sun, 13 Feb 2005 08:20:17 GMT
     [ http://issues.apache.org/jira/browse/JCR-46?page=comments#action_59108 ]
     
Jukka Zitting commented on JCR-46:
----------------------------------

Background and solution from my earlier message to jacrabbit-dev:

<summary>
Place xalan.jar in $MAVEN_HOME/lib/endorsed to build the latest (since 
2004-12-22) Jackrabbit sources with JDK 1.5.
</summary>

Below is a description of the details of the problem. I hope someone
finds this useful.

I ran into the same problem as Oliver Kiessler after updating my source
tree. I'd like to keep using JDK 1.5, so I first traced the problem to
the following lines in maven.xml (line breaks added for clarity):

<!-- The following is a hack to get xslt work with maven
      (See: http://maven.apache.org/faq.html#BadXSLT ) -->
${systemScope.setProperty(
      'javax.xml.transform.TransformerFactory',
      'org.apache.xalan.processor.TransformerFactoryImpl')}

The JavaCC grammar in src/grammar/xpath makes heavy use of XSLT, and the
following ant:xslt entries in maven.xml handle the transformations:

       <ant:xslt style="src/grammar/xpath/strip.xsl"
              in="src/grammar/xpath/xpath-grammar.xml"
              out="src/grammar/xpath/stripped-xpath-grammar.xml"
              force="yes">
       </ant:xslt>
       <ant:xslt style="src/grammar/xpath/jjtree-jackrabbit.xsl"
              in="src/grammar/xpath/stripped-xpath-grammar.xml"
              out="src/grammar/xpath/XPath.jjt"
              force="yes">
       </ant:xslt>

The systemScope.setProperty() hack is needed to make the ant:xslt task
work properly with Maven (see [1]). However, as mentioned in the
comments of the associated bug entry [2], this hack doesn't work with
JDK 1.5 that uses the new Xalan XSLTC compiler at
com.sum.org.apache.xalan.internal.xsltc.trax.TransformerFactoryImpl.

Unfortunately the problem could not be solved by simply changing the
systemScope.setProperty() line because the XSLTC version bundled with
JDK 1.5 has problems with named templates (probably bug [3]). Instead of
the "provider not found" errors from ant:xslt, I now received
NoSuchMethodError exceptions from XSLTC.

As an alternative solution, I then downloaded the normal Xalan binaries
and placed xalan.jar in $MAVEN_HOME/lib/endorsed. I was then able to run
maven jar without problems. Note that the library needs to be placed in
lib/endorsed instead of just lib to make the Xalan classes visible for
the ant:xslt task.

Although this solution is a bit of a hack, I don't think a better one is
possible until either the Maven problem gets solved or the JDK XSLTC
gets fixed.

BR,

Jukka Zitting

[1] http://maven.apache.org/faq.html#BadXSLT
[2] http://jira.codehaus.org/secure/ViewIssue.jspa?key=MAVEN-156
[3] http://issues.apache.org/jira/browse/XALANJ-1994


> Provider org.apache.xalan.processor.TransformerFactoryImpl not found
> --------------------------------------------------------------------
>
>          Key: JCR-46
>          URL: http://issues.apache.org/jira/browse/JCR-46
>      Project: Jackrabbit
>         Type: Bug
>   Components: maven
>  Environment: JDK 1.5, Maven 1.0.2
>     Reporter: Jukka Zitting
>     Assignee: Jukka Zitting

>
> "maven jar" fails with the following error message on a fresh Jackrabbit source tree:
> BUILD FAILED
> File...... /home/hukka/tmp/jackrabbit/maven.xml
> Element... ant:xslt
> Line...... 146
> Column.... 25
> Provider org.apache.xalan.processor.TransformerFactoryImpl not found
> Total time: 4 seconds
> Finished at: Sun Feb 13 10:09:03 EET 2005

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message