jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Guggisberg <stefan.guggisb...@gmail.com>
Subject Re: Initial maven files
Date Mon, 27 Sep 2004 13:50:25 GMT
ok, one thing i forgot:

removing the jcr-0.14beta.jar from the local maven repository breaks
the generated intellij module file (i.e. jackrabbit.iml) because the
classpath entries point to ~/.maven/repository/*

cheers
stefan


On Mon, 27 Sep 2004 15:08:06 +0200, Stefan Guggisberg
<stefan.guggisberg@gmail.com> wrote:
> 
> 
> On Sat, 25 Sep 2004 06:18:56 -0400, Tim Reilly
> <tim.reilly@consultant.com> wrote:
> > > > [Tim Reilly wrote:]
> > > [Stefan Guggisberg wrote:]
> > > > * Check the generated build.xml is not missing
> > > > targets/functionality that
> > > > stefan might have had in the orig build.xml.
> > >
> > > i generated the build.xml. it seems like everything's there. there's
> > > only a minor problem with the jcr-0.14beta.jar. when trying to run the
> > > ant script, i keep getting the following error:
> > >
> > >       [get] Getting:
> > > http://www.ibiblio.org/maven/jcr-api/jars/jcr-0.14beta.jar
> > >     [get] Error opening connection java.io.IOException
> > >     [get] Error opening connection java.io.IOException
> > >     [get] Error opening connection java.io.IOException
> > >     [get] Can't get
> > http://www.ibiblio.org/maven/jcr-api/jars/jcr-0.14beta.jar
> > >  to D:\dev\jsr170\jackrabbit\target\lib\jcr-0.14beta.jar
> > >
> > > i have copied the jar to my local repository (i.e.
> > > %userprofile%\.maven\repository\jcr-api\jars\jcr-0.14beta.jar), but
> > > the build script doesn't check the local rep. when i manually copy it
> > > to target/lib, there is still the error msg but the build succeeds.
> > >
> > > any ideas?
> >
> > I've added a postGoal to the ant:generate-build goal to inject
> > /lib/**/*.jar into the classpath.
> > Could you verify the latest changes fix the issue?
> 
> i did a fresh checkout, removed the jcr-0.14beta.jar from the local repository
> and ran "maven ant" to genereate the build.xml.
> 
> invoking "ant" however still produced the same error msg's:
> 
> get-deps:
> ...
> [get] Getting: http://www.ibiblio.org/maven/jcr-api/jars/jcr-0.14beta.jar
> [get] Error opening connection java.io.IOException
> ...
> [get] Can't get
> http://www.ibiblio.org/maven/jcr-api/jars/jcr-0.14beta.jar to
> D:\dev\jsr170\jackrabbit\target\lib\jcr-0.14beta.jar
> 
> ant reported "BUIILD SUCCESSFUL" though and jackrabbit-0.14-dev.jar
> was found in ./target.
> 
> i guess that since the build succeeds it is now only a cosmetical
> issue (the error msg).
> 
> cheers
> stefan
> 
> 
> 
> >
> > If it's ok, then whenever dependency versions change we can $>maven ant and
> > commit the updated build.xml to svn.
> >
> > Thanks,
> > -TR
> >
> >
>

Mime
View raw message