jackrabbit-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From resc...@apache.org
Subject svn commit: r1860558 - /jackrabbit/branches/2.14/RELEASE-NOTES.txt
Date Mon, 03 Jun 2019 13:13:44 GMT
Author: reschke
Date: Mon Jun  3 13:13:44 2019
New Revision: 1860558

URL: http://svn.apache.org/viewvc?rev=1860558&view=rev
Log:
JCR-4445: Release Jackrabbit 2.14.7 - Candidate Release Notes

Modified:
    jackrabbit/branches/2.14/RELEASE-NOTES.txt

Modified: jackrabbit/branches/2.14/RELEASE-NOTES.txt
URL: http://svn.apache.org/viewvc/jackrabbit/branches/2.14/RELEASE-NOTES.txt?rev=1860558&r1=1860557&r2=1860558&view=diff
==============================================================================
--- jackrabbit/branches/2.14/RELEASE-NOTES.txt (original)
+++ jackrabbit/branches/2.14/RELEASE-NOTES.txt Mon Jun  3 13:13:44 2019
@@ -1,65 +1,69 @@
-Release Notes -- Apache Jackrabbit -- Version 2.14.6
+Release Notes -- Apache Jackrabbit -- Version 2.14.7
 
 Introduction
 ------------
 
-This is Apache Jackrabbit(TM) 2.14.6, a fully compliant implementation of the
+This is Apache Jackrabbit(TM) 2.14.7, a fully compliant implementation of the
 Content Repository for Java(TM) Technology API, version 2.0 (JCR 2.0) as
 specified in the Java Specification Request 283 (JSR 283).
 
-Apache Jackrabbit 2.14.6 is a patch release that contains fixes and
+Apache Jackrabbit 2.14.7 is a patch release that contains fixes and
 improvements over Jackrabbit 2.14. Jackrabbit 2.14.x releases are
 considered stable and targeted for production use.
   
-Changes in Jackrabbit 2.14.6
+Changes in Jackrabbit 2.14.7
 ----------------------------
 
 Bug
 
-    [JCR-4093] - IndexRule are meant to be applied based on both primaryType and minin type
based inheritance. Currently it appears that only primaryType based inheritance is working
-    [JCR-4291] - FileInputStream for workspace.xml not closed in RepositoryConfig.loadWorkspaceConfig(File)
-    [JCR-4317] - davex remoting fails for non-ASCII characters in node names
-    [JCR-4324] - NPE on Version.getLinearPredecessor() implementation
-
-Improvement
-
-    [JCR-3211] - Support HTTP proxy in SPI2DAV
-    [JCR-4253] - RepositoryConfig: add some handling for mkdir failure
-    [JCR-4292] - davex: preserve cause in exceptions and log affected URI
+    [JCR-4120] - Spi2DavexRepositoryServiceImpl always hardcodes the default workspace name
to "default"
+    [JCR-4339] - Indexing configuration condition property seems to be broken
+    [JCR-4387] - Incorrect exception message when same-name-sibling is prevented on import
+    [JCR-4420] - Release Notes: term "SHA1" no longer allowed
 
 Task
 
-    [JCR-4254] - Update Logback version to >= 1.2.0, SLF4J accordingly
-    [JCR-4256] - create announcement mail template for releases
-    [JCR-4261] - webapp: align jsons-simple dependencies internally and with oak
-    [JCR-4262] - jcr-server: align org.apache.felix.scr.annotations with oak
-    [JCR-4263] - jcr-server, jackrabbit-bundle: align org.osgi dependencies with oak
-    [JCR-4264] - jackrabbit-standalone: align commons-cli dependency with oak
-    [JCR-4272] - Upgrade surefire and failsafe plugins to 2.21.0
-    [JCR-4288] - Upgrade tika-parsers dependency to 1.18
-    [JCR-4290] - remove unused commons-codec dependency
-    [JCR-4293] - jackrabbit-core: observation tests should not rely on mix:lockable mixin
type
-    [JCR-4294] - TCK tests should pass on repositories without locking support
-    [JCR-4296] - Upgrade httpmime dependency to 4.5.5
-    [JCR-4302] - BTreeManager: fix Eclipse compiler error
-    [JCR-4304] - update Jetty to supported version 9.2.*
-    [JCR-4307] - Update animal-sniffer-maven-plugin to 1.16
-    [JCR-4318] - Update failsafe and surefire plugin versions to 2.22.0
-    [JCR-4320] - Update spotbugs plugin to 3.1.5
-    [JCR-4321] - Update maven plugins from org.apache.maven.plugins
-    [JCR-4322] - Consistent use of log4j versions
-    [JCR-4323] - webapp: update Tomcat dependency to 8.5.32
-    [JCR-4326] - Update aws java sdk version to 1.11.330 (consistent with Oak)
-    [JCR-4327] - Update httpcore dependency to 4.4.10
-    [JCR-4331] - Update httpclient dependency to 4.5.6
-    [JCR-4332] - Update httpmime dependency to 4.5.6
-    [JCR-4333] - Update javax.transaction dependency to 1.3
+    [JCR-4140] - Update easymock dependency to 3.4
+    [JCR-4229] - Remove Oak dependency in webapp
+    [JCR-4336] - Upgrade commons-dbcp dependencies
+    [JCR-4343] - Update commons-vfs2 version to 2.2
+    [JCR-4344] - Update h2db version to latest stable 1.4.196
+    [JCR-4345] - Update mockito dependency to 2.20.0
+    [JCR-4346] - Update easymock dependency to 3.6
+    [JCR-4347] - Update com.jcraft.jsch dependency to 0.1.54
+    [JCR-4348] - Update osgi (compendium, core) dependencies
+    [JCR-4349] - Update plexus-utils dependency to 3.1.0
+    [JCR-4350] - jackrabbit-jcr-servlet: remove special-cased servlet-api dependency
+    [JCR-4359] - update maven-bundle-plugin to 3.5.0
+    [JCR-4360] - update maven-scr-plugin to 1.26.0
+    [JCR-4361] - Update spotbugs plugin to 3.1.6
+    [JCR-4362] - Update tomcat dependency to 8.5.33
+    [JCR-4363] - Update mockito dependency to 2.21.0
+    [JCR-4364] - update org.apache.felix.scr.annotations dependency to 1.12.0
+    [JCR-4365] - Update cglib dependency to 3.2.8
+    [JCR-4368] - Update commons-cli dependency to 1.4
+    [JCR-4372] - Update mockito dependency to 2.22.0
+    [JCR-4373] - webapp: update Tomcat dependency to 8.5.34
+    [JCR-4381] - Update failsafe and surefire plugin versions to 2.22.1
+    [JCR-4382] - Update spotbugs plugin to 3.1.7
+    [JCR-4383] - Update animal-sniffer-maven-plugin to 1.17
+    [JCR-4385] - Update maven-war-plugin to 3.2.2
+    [JCR-4386] - remove unused jxr dependency
+    [JCR-4388] - Update mockito dependency to 2.23.0
+    [JCR-4403] - update spotbugs dependency to 3.1.10
+    [JCR-4404] - update maven-assembly-plugin dependency to 3.1.1
+    [JCR-4405] - update maven-jar-plugin dependency to 3.1.1
+    [JCR-4407] - Update httpcore dependency to 4.4.11
+    [JCR-4409] - jackrabbit-webapp: embed JCR 2.0 API
+    [JCR-4410] - jackrabbit-webapp: cleanup left over Oak references
+    [JCR-4411] - Update httpclient/mime dependencies to 4.5.7
+    [JCR-4415] - Update Jetty dependency to 9.2.26.v20180806
+    [JCR-4416] - Update slf4j dependency to 1.7.26
+    [JCR-4422] - Update httpclient/mime dependencies to 4.5.8
 
 Sub-task
 
-    [JCR-4280] - code coverage checks fail on Java 10
-    [JCR-4306] - switch to findbugs replacement that is still maintained (spotbugs)
-    [JCR-4338] - avoid use of javax.rmi.PortableRemoteObject (removed in Java 11)
+    [JCR-4357] - upgrade to Jacoco version compatible with Java 11
 
 
 For more detailed information about all the changes in this and other



Mime
View raw message