isis-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Haywood <>
Subject Re: Warning a user based on input on action invocation
Date Fri, 23 Nov 2018 16:05:54 GMT
Yeah, I think this is a great idea.

How about "advise" as a prefix to me; as in we are providing advice.  Also
sounds "softer" in tone than "warn".

I guess it'll introduce a new phase ... hide, disable, validate, advise,
executing, executed.  So might be quite a bit of work to implement, but I
can see the value.

What do others think?


On Fri, 23 Nov 2018 at 15:56, Sander Ginn <> wrote:

> Hi,
> We’ve had a number of support requests relating to new users of our
> application that are not yet fully familiar with their business process.
> We do not wish to invalidate input as many business rules are not clearly
> defined in a ‘correct/incorrect’ fashion, with many exceptions and special
> cases.
> As a middle ground, I would like to propose an extension of the metamodel
> with a support method similar to validateXxx(), which renders the familiar
> dialog and warning message underneath the input field with another colour
> (yellow, probably) but does not block the user from completing the action.
> Does anyone else consider this to be a useful addition, and if so, what
> would be a good method prefix? My first thought was warnXxx(), but that
> does not make a lot of sense syntactically; after all, we aren’t warning
> the action in question (as opposed to validate/hide/disableXxx()) but the
> user instead.
> Best
> Sander Ginn

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message