isis-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "zcy@ejustcn.com" <...@ejustcn.com>
Subject some domainservice does not instantiate properly
Date Wed, 05 Sep 2018 06:39:38 GMT






Hi, I create a project from incode quickstart app archetype. And when I deploy the application,
there are some domainservices can not be instantiate properly.After track down I found module
webapp's dependcy ognl which depends on javassist 3.11. But javassist 3.11 can not work on
JDK 8.The application has two version of javassist denpendcies. So just add  exclusion clause
like below to resolve the problem:<dependency>

                    <groupId>ognl</groupId>

                    <artifactId>ognl</artifactId>

                    <version>${ognl.version}</version>

                    <exclusions>

                        <exclusion>

                            <groupId>org.javassist</groupId>

                            <artifactId>javassist</artifactId>

                        </exclusion>

                    </exclusions>

                </dependency>
Thanks.
James Chu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message