isis-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerrie Myburgh <gerrie.mybu...@yahoo.co.uk.INVALID>
Subject dependent class not found.
Date Sun, 15 Jul 2018 07:30:31 GMT
Hi,
I took simple app, removed simple module and added another module. When I run the app in the
IDE it run's fine but the moment I deploy to tomcat I get a :
java.lang.ClassNotFoundException: domainapp.modules.simple.SimpleModule

What is frustrating is that I cannot find any reference to SimpleModule anywhere in my code. 
Here is the error message in the catalina log:
1) Error in custom provider, org.apache.isis.core.commons.factory.InstanceCreationClassException:
Class 'class domainapp.application.manifest.DomainAppAppManifest'found , but is missing a
dependent class: domainapp/modules/simple/SimpleModule  at org.apache.isis.core.runtime.runner.IsisInjectModule.provideIsisSessionFactory(IsisInjectModule.java:109) 
at org.apache.isis.core.runtime.runner.IsisInjectModule.provideIsisSessionFactory(IsisInjectModule.java:109) 
while locating org.apache.isis.core.runtime.system.session.IsisSessionFactory    for field
at org.apache.isis.viewer.wicket.viewer.IsisWicketApplication.isisSessionFactory(IsisWicketApplication.java:155) 
while locating domainapp.webapp.DomainApplication
And first exception stackstace
Caused by: java.lang.ClassNotFoundException: domainapp.modules.simple.SimpleModule at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1308)
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1136)
... 81 more
Has anyone had a similar problem and how did they find the reference to SimpleModule in order
to remove it.
Thanks
Gerrie


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message