isis-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Cameron <steve.cameron...@gmail.com>
Subject Interface support
Date Fri, 19 Jan 2018 11:27:42 GMT
Hi,

I'm trying to make use of Java interfaces, seems they are supported by
DataNucleus, but may not by Apache Isis from the follow build error message?

[ERROR] Failed to execute goal
org.apache.isis.tool:isis-maven-plugin:1.16.0:validate (default) on project
event-schedule-module-base: Execution default of goal
org.apache.isis.tool:isis-maven-plugin:1.16.0:validate failed: Non-enhanced
@PersistenceCapable classes found, will abort.  The classes in error are:
[ERROR]
[ERROR] * au.com.scds.eventschedule.base.EventAttendance
[ERROR]
[ERROR] Did the DataNucleus enhancer run correctly?


Where EventAttendance is an interface

@PersistenceCapable(identityType=IdentityType.DATASTORE)
public interface EventAttendance {

    @Persistent
    public Event getEvent();
    @Persistent
    public Attendee getAttendee();
}

Not a critical issue, I'm just experimenting.

Steve

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message