isis-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Haywood <...@haywood-associates.co.uk>
Subject 1.9.0-SNAPSHOT now on DN 4.1
Date Tue, 04 Aug 2015 06:11:17 GMT
Hi folks,

Just a heads-up that (per ISIS-1153) I've updated our dependency on
DataNucleus from 4.0.x to the latest, ie 4.1.2.

The only change to your dom code is that the datanucleus-maven-plugin
version has changed from 4.0.0-release to 4.0.1.

This is updated in the migration notes, see [1] also in the user guide
[2].  The archetype has also been updated.

One thing to be aware of: internally DN has changed one of its interfaces,
so that enhanced classes now implement
org.datanucleus.enhancement.Persistable, rather than
org.datanucleus.enhancer.Persistable.  So if you see any strange errors to
do with class loading, it may be that your mvn is picking up an old version
of some class.  In such a case you might want to clear out your local mvn
repo under ~/.m2/repository/org/apache/isis and
~/.m2/repository/org/isisaddons.

Thanks
Dan



[1] http://isis.apache.org/migration-notes.html
[2
http://isis.apache.org/guides/ug.html#_ug_getting-started_datanucleus-enhancer

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message