isis-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Wood-Patrick" <mwoodpatr...@gmail.com>
Subject RE: Example of adding new class to examples
Date Sat, 29 Dec 2012 15:48:38 GMT
Yes that was the problem

Many thanks

Mark

-----Original Message-----
From: Dan Haywood [mailto:dan@haywood-associates.co.uk] 
Sent: Friday, December 28, 2012 3:39 PM
To: users
Subject: RE: Example of adding new class to examples

Haven't pulled down the repo yet, but have you registered your service in
Isis.properties?

Dan

Sorry to be brief, sent from my phone
On Dec 28, 2012 11:33 PM, "Mark Wood-Patrick" <mwoodpatrick@gmail.com>
wrote:

> Looks like I was building in the wrong directory fixing that I get the 
> class files being build but the new class is not showing up in the UI 
> any ideas?
> I
> created a repository at:
>
>         https://github.com/mwoodpatrick/quickstart_wicket_restful_jdo
>
> Mark
>
> -----Original Message-----
> From: Adam Howard [mailto:howard.adam@gmail.com]
> Sent: Friday, December 28, 2012 9:44 AM
> To: users@isis.apache.org
> Subject: Re: Example of adding new class to examples
>
> Are you running `mvn clean install` from the command line or within 
> Eclipse?
> I believe there are two separate target folders now depending on what 
> profiles are active. Command line maven builds into target/classes 
> while Eclipse builds into target-ide/classes.
>
> Are you looking in the right folder to find the class files?
>
> --
> Adam Howard
>
>
> On Fri, Dec 28, 2012 at 10:41 AM, Dan Haywood
> <dan@haywood-associates.co.uk>wrote:
>
> > To answer the question, there are no docs... they are just java 
> > classes that live in the appropriate directory.
> >
> > What you've added looks correct.  Could you upload to a new github 
> > repo so we can see the problem?
> >
> > Sorry to be brief, sent from my phone On Dec 28, 2012 4:10 PM, "Mark 
> > Wood-Patrick" <mwoodpatrick@nvidia.com>
> > wrote:
> >
> > > I'm trying to add a new class 'Tool' to the 1.0.0 archetype I have 
> > > implemented classes:
> > >
> > > ../dom/src/main/java/dom/tool/Tool.java
> > > ../dom/src/main/java/dom/tool/Tools.java
> > > ../fixture/src/main/java/fixture/tool/ToolFixture.java
> > > ../fixture/src/main/java/fixture/tool/ToolsFixturesService.java
> > >
> > > But when I run
> > >
> > >         mvn clean install
> > >
> > > it does not compile these, what am I doing wrong?
> > >
> > > Do we have docs on how to add a new class to the archetype?
> > >
> > > Thanks in advance
> > >
> > > Mark Wood-Patrick
> > >
> > >
> > >
> > >
> > --------------------------------------------------------------------
> > --
> > -------------
> > > This email message is for the sole use of the intended 
> > > recipient(s) and may contain confidential information.  Any 
> > > unauthorized review, use, disclosure or distribution is 
> > > prohibited.  If you are not the intended recipient, please contact 
> > > the sender by reply email and destroy all copies of the original
message.
> > >
> > >
> >
>
> ----------------------------------------------------------------------
> ------
> -------
> > >
> >
>
>


Mime
View raw message