infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Drew Foulks (Jira)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-18883) Install Ruby >= 2.4 for Flink buildbot
Date Wed, 04 Sep 2019 15:50:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-18883?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16922618#comment-16922618
] 

Drew Foulks commented on INFRA-18883:
-------------------------------------

it looks like the puppet was trying to install jekyll 4 and failing out, causing the puppet
run to finish with errors. I've got a PR out there currently to hard set the jekyll version.
In the meantime, rvm should be available.

> Install Ruby >= 2.4 for Flink buildbot
> --------------------------------------
>
>                 Key: INFRA-18883
>                 URL: https://issues.apache.org/jira/browse/INFRA-18883
>             Project: Infrastructure
>          Issue Type: Wish
>          Components: Buildbot
>            Reporter: Nico Kruber
>            Assignee: Drew Foulks
>            Priority: Major
>
> Hey Infra-Team!
> Is it possible to get a newer Ruby version in the buildbot environment on {{bb_slave2_ubuntu}}?
We use buildbot for generating Flink docs via Jekyll and the currently installed version is
2.3.1 (see https://github.com/apache/infrastructure-puppet/blob/deployment/data/nodes/bb-slave2.apache.org.yaml)
> We want to upgrade Jekyll since the new version builds the docs much faster but that
requires the newer Ruby version (>= 2.4.0). I think, installing it in addition to 2.3.1
should not be a problem and we can then switch once we are ready).
> The related Flink ticket is https://issues.apache.org/jira/browse/FLINK-13726



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message