infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-18866) CMS build failing
Date Tue, 13 Aug 2019 11:38:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-18866?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16906105#comment-16906105
] 

Sebb commented on INFRA-18866:
------------------------------

I was able to get Perl working with curl.

However, the JIRA extraction then failed; this seems to be the same issue.
The JIRA code [1] also uses LWP::Simple.

I can potentially change that to curl as well, but AFAICT the CMS code does not seem to auto-deployed
(I made another change that should have generated some output in the build log which did not
appear).

How to get the CMS code updated?

[1] https://svn.apache.org/repos/infra/websites/cms/build/lib/ASF/Value/Jira.pm

> CMS build failing
> -----------------
>
>                 Key: INFRA-18866
>                 URL: https://issues.apache.org/jira/browse/INFRA-18866
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: CMS
>            Reporter: Sebb
>            Priority: Major
>
> CMS builds are failing for www.a.o with an unexplained URL error:
> https://ci.apache.org/builders/www-site-staging/builds/3479/steps/compile/logs/stdio
> Building content/index.html ...
> Can't get projects list (https://projects.apache.org/json/foundation/projects.json):

> program finished with exit code 255
> No idea what is happening here because the URL works for me.
> Unfortunately view.pm [1] uses LWP::Simple which does not give any error messages.
> Maybe something needs kicking/restarting?
> [1] https://svn.apache.org/repos/asf/infrastructure/site/trunk/lib/view.pm



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message