infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrea Del Bene (JIRA)" <j...@apache.org>
Subject [jira] [Created] (INFRA-18741) Buildbot: maven-javadoc-plugin 3.1.x fails with Java 8 as default
Date Fri, 12 Jul 2019 13:59:00 GMT
Andrea Del Bene created INFRA-18741:
---------------------------------------

             Summary: Buildbot: maven-javadoc-plugin 3.1.x fails with Java 8 as default
                 Key: INFRA-18741
                 URL: https://issues.apache.org/jira/browse/INFRA-18741
             Project: Infrastructure
          Issue Type: Bug
          Components: Buildbot
            Reporter: Andrea Del Bene


Hi,

working on master branch (https://ci.apache.org/builders/wicket-master) of  Apache Wicket
we have upgraded maven-javadoc-plugin to the last version 3.1.0 and then to 3.1.1. Starting
with 3.1.0 we started to see this plugin failing generating JavaDocs for Wicket complaining
about not existing packages. For example:

[ERROR] MavenReportException: Error while generating Javadoc: 
Exit code: 1 - /home/buildslave/slave/wicket-master/build/wicket-util/src/main/java/org/apache/wicket/util/license/ApacheLicenseHeaderTestCase.java:32:
error: package org.slf4j does not exist
import org.slf4j.Logger;

Master branch requires Java 11 and is configured to use it via toolchain. After some investigation
I've been able to replicate this error running the build process with Java 8 (instead of Java
11) as default JDK. I suspect that we have the same configuration for the master branch worker.
With Java 11 as default JDK everything works fine.
Is it possible to set JAVA_HOME to java 11 for master branch builder?

Thank you. 




--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message