infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Munteanu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (INFRA-17796) H29 does not have the apache snapshots repository configured
Date Mon, 25 Feb 2019 09:42:00 GMT

     [ https://issues.apache.org/jira/browse/INFRA-17796?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Munteanu updated INFRA-17796:
------------------------------------
    Status: Waiting for Infra  (was: Waiting for user)

With Maven you can't really 'ask' a repository for snapshots or releases. With Maven you ask
for a dependency and then Maven looks into the configured repositories.

In your Maven project we only define dependencies, not repositories. Repositories come from
the ASF parent pom ( see https://github.com/apache/maven-apache-parent/blob/apache-21/pom.xml#L97-L106
).

The problem we have seen on H29 is that the snapshots repository is never consulted, even
though it should be. We have made the debug logs available as you have asked in hopes that
it will point out what the problem is.

I have tried nuking the local Maven repository on my workstation and a clean build still works.
I am using the same version as on Jenkins (3.6.0) .

So I have amended the issue title to reflect that this is not a problem with the Maven settings.xml
. To be honest I have no good idea what the problem can be so I have temporarily excluded
H29 from our builds.

I have two wild guesses:

- a corrupt/invalid ASF parent pom on H29
- a problem with the way Maven works on Jenkins ( pipeline-maven-plugin? ) 

For the first I could suggest wiping out the $HOME/.repository/org/apache/apache folder and
see if a fresh download fixes it.
For the second I have no idea how to validate.

Any other ideas for debugging are more than welcome

> H29 does not have the apache snapshots repository configured
> ------------------------------------------------------------
>
>                 Key: INFRA-17796
>                 URL: https://issues.apache.org/jira/browse/INFRA-17796
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Jenkins
>            Reporter: Robert Munteanu
>            Assignee: Chris Lambertus
>            Priority: Major
>         Attachments: failing-jenkins-job.txt
>
>
> One of our Maven builds has started failing, complaining that it cannot find a SNAPSHOT
dependency
> - https://builds.apache.org/job/Sling/job/sling-org-apache-sling-launchpad-testing/job/master/10/console
> - https://builds.apache.org/job/Sling/job/sling-org-apache-sling-launchpad-testing/job/master/11/console
> Both builds took place on H29. The error message is
> [ERROR] Unable to get artifact for Dependency {groupId=org.apache.sling, artifactId=org.apache.sling.launchpad.test-bundles,
version=12-SNAPSHOT, type=slingfeature}: Could not find artifact org.apache.sling:org.apache.sling.launchpad.test-bundles:txt:12-SNAPSHOT
> [ERROR] 
> [ERROR] Try downloading the file manually from the project website.
> [ERROR] 
> [ERROR] Then, install it using the command: 
> [ERROR]     mvn install:install-file -DgroupId=org.apache.sling -DartifactId=org.apache.sling.launchpad.test-bundles
-Dversion=12-SNAPSHOT -Dpackaging=slingfeature -Dfile=/path/to/file
> [ERROR] 
> [ERROR] Alternatively, if you host your own repository you can deploy the file there:

> [ERROR]     mvn deploy:deploy-file -DgroupId=org.apache.sling -DartifactId=org.apache.sling.launchpad.test-bundles
-Dversion=12-SNAPSHOT -Dpackaging=slingfeature -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
> [ERROR] 
> [ERROR] 
> [ERROR]   org.apache.sling:org.apache.sling.launchpad.test-bundles:slingfeature:12-SNAPSHOT
> [ERROR] 
> [ERROR] from the specified remote repositories:
> [ERROR]   central (https://repo.maven.apache.org/maven2, releases=true, snapshots=false)
> [ERROR] -> [Help 1]
> [ERROR] 
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR] 
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MavenExecutionException
> [Pipeline] }
> Note that only lists Maven Central as a repository.
> A previous build on H26 worked just fine
> https://builds.apache.org/job/Sling/job/sling-org-apache-sling-launchpad-testing/job/master/9/consoleFull
> and I can see the SNAPSHOT artifacts downloaded just fine there
> [INFO] Downloading from Nexus: http://repository.apache.org/snapshots/org/apache/sling/org.apache.sling.launchpad.test-bundles/12-SNAPSHOT/maven-metadata.xml
> [INFO] Downloaded from Nexus: http://repository.apache.org/snapshots/org/apache/sling/org.apache.sling.launchpad.test-bundles/12-SNAPSHOT/maven-metadata.xml
(1.0 kB at 3.4 kB/s)
> [INFO] Downloading from Nexus: http://repository.apache.org/snapshots/org/apache/sling/org.apache.sling.launchpad.test-bundles/12-SNAPSHOT/org.apache.sling.launchpad.test-bundles-12-20190131.161011-67.txt
> [INFO] Downloaded from Nexus: http://repository.apache.org/snapshots/org/apache/sling/org.apache.sling.launchpad.test-bundles/12-SNAPSHOT/org.apache.sling.launchpad.test-bundles-12-20190131.161011-67.txt
(1.7 kB at 5.6 kB/s)
> And note that they are still present in the snapshots repo
> http://repository.apache.org/snapshots/org/apache/sling/org.apache.sling.launchpad.test-bundles/12-SNAPSHOT/maven-metadata.xml
> https://repository.apache.org/content/groups/snapshots/org/apache/sling/org.apache.sling.launchpad.test-bundles/12-SNAPSHOT/
> Can you please check why H29 does not have the ASF snapshots repository configured?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message