infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lambertus (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (INFRA-16704) lists.a.o: timestamp on From_ lines not in UTC
Date Thu, 31 Jan 2019 04:41:00 GMT

     [ https://issues.apache.org/jira/browse/INFRA-16704?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Lambertus resolved INFRA-16704.
-------------------------------------
    Resolution: Fixed

I verified this is working now.

>From PonEE:

It seems to indicate a bug in the stack used
by Apache Pony Mail, namely that Postfix does not strictly conform to
RFC 4155. We are discussing whether to report this with upstream, but
for now we have set our MTAs to change the timestamp to UTC to work
around the upstream bug. We have not found that this behaviour was
caused by any part of PonEE.

Since "From" lines do not indicate when a message was sent, only the
date and time when the message was received by the final MTA, we do
not recommend using timestamps in "From" lines as a canonical source
of any metadata. Furthermore you may be reassured to hear that nothing
discussed in this thread affects the internal timestamps, which are
always in UTC.

> lists.a.o: timestamp on From_ lines not in UTC
> ----------------------------------------------
>
>                 Key: INFRA-16704
>                 URL: https://issues.apache.org/jira/browse/INFRA-16704
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Mail Archives
>            Reporter: Sebb
>            Assignee: Chris Lambertus
>            Priority: Major
>
> The timestamp on From_ lines is supposed to be in UTC.
> However, AFAICT it is in CEST.
> Examples:
> [1] From line clearly in CEST as time matches received line
> [2] Does not have a From line in the source, so it should be calculated in UTC by the
mbox download script. However the value is:
> ---- cut here ---
> From dev-return-842-archive-asf-public=cust-asf.ponee.io@ponymail.incubator.apache.org
Mon Jul 31 22:22:03 2017
> Return-Path: <dev-return-842-archive-asf-public=cust-asf.ponee.io@ponymail.incubator.apache.org>
> X-Original-To: archive-asf-public-internal@cust-asf2.ponee.io
> Delivered-To: archive-asf-public-internal@cust-asf2.ponee.io
> Received: from cust-asf.ponee.io (cust-asf.ponee.io [163.172.22.183])
> 	by cust-asf2.ponee.io (Postfix) with ESMTP id D9BD0200CFE
> 	for <archive-asf-public-internal@cust-asf2.ponee.io>; Mon, 31 Jul 2017 22:22:03
+0200 (CEST)
> ---- cut here ---
> Note that the first and last lines show the same hour (22), but the first is supposed
to be UTC and the second is +0200 (CEST)
> The From line should have the timestamp 'Mon Jul 31 20:22:03 2017'
> I think there are two problems here:
> 1) the server should be running as UTC to avoid any possible TZ issues
> 2) it looks like to code to generate the timestamp is not working correctly or is not
the same as in the release 0.10 [3]
> [1] https://lists.apache.org/api/source.lua/4e6de8867b3f5002ba2bb00c4c80c39481c041606fbc43e17f6a07b7@%3Cdev.ponymail.apache.org%3E
> [2] https://lists.apache.org/api/source.lua/7e40a760de30cdae6778bcc6d9679251824ffe1c1880e1144a2d0121@%3Cdev.ponymail.apache.org%3E
> [3] https://github.com/apache/incubator-ponymail/blob/0.10/site/api/mbox.lua#L51



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message