infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lambertus (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (INFRA-16704) lists.a.o: timestamp on From_ lines not in UTC
Date Tue, 29 Jan 2019 04:08:00 GMT

     [ https://issues.apache.org/jira/browse/INFRA-16704?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Lambertus updated INFRA-16704:
------------------------------------
    Status: Waiting for user  (was: Waiting for Infra)

Here is PonEE's reply:

Archives are being properly saved using UTC in the internal database.
However, it would seem that we had an incompatibility issue with a
patch in the output stream generator for mbox files, and it was held
back. This has now been addressed, and mbox files should now properly
generate timestamps using UTC.


Is there anything further to do on this ticket?

> lists.a.o: timestamp on From_ lines not in UTC
> ----------------------------------------------
>
>                 Key: INFRA-16704
>                 URL: https://issues.apache.org/jira/browse/INFRA-16704
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Mail Archives
>            Reporter: Sebb
>            Assignee: Chris Lambertus
>            Priority: Major
>
> The timestamp on From_ lines is supposed to be in UTC.
> However, AFAICT it is in CEST.
> Examples:
> [1] From line clearly in CEST as time matches received line
> [2] Does not have a From line in the source, so it should be calculated in UTC by the
mbox download script. However the value is:
> ---- cut here ---
> From dev-return-842-archive-asf-public=cust-asf.ponee.io@ponymail.incubator.apache.org
Mon Jul 31 22:22:03 2017
> Return-Path: <dev-return-842-archive-asf-public=cust-asf.ponee.io@ponymail.incubator.apache.org>
> X-Original-To: archive-asf-public-internal@cust-asf2.ponee.io
> Delivered-To: archive-asf-public-internal@cust-asf2.ponee.io
> Received: from cust-asf.ponee.io (cust-asf.ponee.io [163.172.22.183])
> 	by cust-asf2.ponee.io (Postfix) with ESMTP id D9BD0200CFE
> 	for <archive-asf-public-internal@cust-asf2.ponee.io>; Mon, 31 Jul 2017 22:22:03
+0200 (CEST)
> ---- cut here ---
> Note that the first and last lines show the same hour (22), but the first is supposed
to be UTC and the second is +0200 (CEST)
> The From line should have the timestamp 'Mon Jul 31 20:22:03 2017'
> I think there are two problems here:
> 1) the server should be running as UTC to avoid any possible TZ issues
> 2) it looks like to code to generate the timestamp is not working correctly or is not
the same as in the release 0.10 [3]
> [1] https://lists.apache.org/api/source.lua/4e6de8867b3f5002ba2bb00c4c80c39481c041606fbc43e17f6a07b7@%3Cdev.ponymail.apache.org%3E
> [2] https://lists.apache.org/api/source.lua/7e40a760de30cdae6778bcc6d9679251824ffe1c1880e1144a2d0121@%3Cdev.ponymail.apache.org%3E
> [3] https://github.com/apache/incubator-ponymail/blob/0.10/site/api/mbox.lua#L51



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message