infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (INFRA-16810) Please introduce a "Ant 1.9.x latest" installation for Jenkins jobs
Date Wed, 25 Jul 2018 05:34:00 GMT

     [ https://issues.apache.org/jira/browse/INFRA-16810?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gavin reassigned INFRA-16810:
-----------------------------

    Assignee: Gavin

> Please introduce a "Ant 1.9.x latest" installation for Jenkins jobs
> -------------------------------------------------------------------
>
>                 Key: INFRA-16810
>                 URL: https://issues.apache.org/jira/browse/INFRA-16810
>             Project: Infrastructure
>          Issue Type: Improvement
>          Components: Jenkins
>            Reporter: jaikiran pai
>            Assignee: Gavin
>            Priority: Major
>
> Right now the "Ant (latest)" choice for Jenkins jobs points to the latest 1.10.x Ant
version which requires Java 8 or higher runtime environment. Certain jobs that we run (for
Ant Ivy project) support Java 7 runtimes, so we would like to use Ant 1.9.x for such jobs.
However, the latest available 1.9.x version for Jenkins jobs right now is 1.9.9. More recent
versions of 1.9.x of Ant have been released and some of them have newer tasks/constructs that
we use in our Ivy build files. Would it be possible to introduce a "Ant 1.9.x latest" selection,
which points to the latest released 1.9.x version (right now it's 1.9.13)?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message