infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Takamori (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (INFRA-16726) Make Gradle 4.8.1 available in Jenkins
Date Thu, 05 Jul 2018 18:15:00 GMT

     [ https://issues.apache.org/jira/browse/INFRA-16726?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Takamori updated INFRA-16726:
------------------------------------
    Status: Waiting for user  (was: Waiting for Infra)

> Make Gradle 4.8.1 available in Jenkins
> --------------------------------------
>
>                 Key: INFRA-16726
>                 URL: https://issues.apache.org/jira/browse/INFRA-16726
>             Project: Infrastructure
>          Issue Type: Task
>          Components: Jenkins
>            Reporter: Ismael Juma
>            Assignee: Daniel Takamori
>            Priority: Major
>
> Maven Central requires TLS 1.2 and Gradle with Java 7 is unable to connect to it unless
4.8.1 or newer is used. As such, if one invokes `gradle` in order to configure the gradle
wrapper, it will fail if the gradle plugins are not cached. For example:
> FAILURE: Build failed with an exception.
> * What went wrong:
> A problem occurred configuring project ':core'.
> > Could not resolve all files for configuration ':core:scoverage'.
>    > Could not resolve org.scoverage:scalac-scoverage-plugin_2.10:1.3.0.
>      Required by:
>          project :core
>       > Could not resolve org.scoverage:scalac-scoverage-plugin_2.10:1.3.0.
>          > Could not get resource 'https://repo.maven.apache.org/maven2/org/scoverage/scalac-scoverage-plugin_2.10/1.3.0/scalac-scoverage-plugin_2.10-1.3.0.pom'.
>             > Could not GET 'https://repo.maven.apache.org/maven2/org/scoverage/scalac-scoverage-plugin_2.10/1.3.0/scalac-scoverage-plugin_2.10-1.3.0.pom'.
>                > Received fatal alert: protocol_version
>    > Could not resolve org.scoverage:scalac-scoverage-runtime_2.10:1.3.0.
>      Required by:
>          project :core
>       > Could not resolve org.scoverage:scalac-scoverage-runtime_2.10:1.3.0.
>          > Could not get resource 'https://repo.maven.apache.org/maven2/org/scoverage/scalac-scoverage-runtime_2.10/1.3.0/scalac-scoverage-runtime_2.10-1.3.0.pom'.
>             > Could not GET 'https://repo.maven.apache.org/maven2/org/scoverage/scalac-scoverage-runtime_2.10/1.3.0/scalac-scoverage-runtime_2.10-1.3.0.pom'.
>                > Received fatal alert: protocol_version
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or --debug option
to get more log output. Run with --scan to get full insights.
> https://builds.apache.org/job/kafka-0.10.1-jdk7/138/console
> Another reason for a newer Gradle is building with Java 11. Gradle 4.4 fails in the following
way:
> 17:08:30 + /home/jenkins/tools/gradle/4.4/bin/gradle
> 17:08:31 
> 17:08:31 FAILURE: Build failed with an exception.
> 17:08:31 
> 17:08:31 * What went wrong:
> 17:08:31 Could not determine java version from '11-ea'.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message