infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lambertus (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (INFRA-16332) buildbot 1.0.0 build slave not working
Date Tue, 03 Jul 2018 05:52:00 GMT

     [ https://issues.apache.org/jira/browse/INFRA-16332?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Lambertus resolved INFRA-16332.
-------------------------------------
    Resolution: Won't Fix

Infra has no immediate plans to upgrade the master to 1.x. As you noted, they are incompatible.
Not only that, but there is no history preservation and all of the conf files are incompatible.
If we do eventually decide to bring up a 1.x master, it will be a completely new system. 

We will not provide any support for project managed buildslaves which are incompatible with
our 0.8.x master.


> buildbot 1.0.0 build slave not working
> --------------------------------------
>
>                 Key: INFRA-16332
>                 URL: https://issues.apache.org/jira/browse/INFRA-16332
>             Project: Infrastructure
>          Issue Type: Project
>          Components: Buildbot
>         Environment: OpenBSD 6.3 / sparc64
> buildbot-worker 1.0.0 installed via 'py-buildslave' OpenBSD package
>            Reporter: Stefan Sperling
>            Assignee: Chris Lambertus
>            Priority: Major
>
> After an upgrade to OpenBSD 6.3 the svn-bb-openbsd build slave is now running buildbot
version 1.0.0 (previous version was 0.8.12).
> I have re-created buildbot.tac from scratch and (after some failed attempts due to wrong
login credentials) the slave now starts and connects successfully.
> However, the 'cleanup' stage is failing with a Python exception:
> Eexceptions.AssertionError: Unexpected usePTY argument value: u'slave-config'. Expected
boolean
> https://ci.apache.org/builders/svn-bb-openbsd/builds/73
> Can somebody please help me figure out what needs to be done to get it working again?
> Perhaps the 'svn-bb-openbsd' configuration directives on the master need to be adjusted
somehow to work with the new version installed on the worker?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message