infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Sperling (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-16332) buildbot 1.0.0 build slave not working
Date Mon, 16 Apr 2018 06:54:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-16332?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16439049#comment-16439049
] 

Stefan Sperling commented on INFRA-16332:
-----------------------------------------

OK,  I can look into downgrading the buildslave package. I don't know if I'll be able to but
we'll see.

I am also fine with just leaving my build slave idle until you find time to upgrade the master,
so you have a 1.0.0 client in the network to test with. It sounds like we should see my build
slave start working again as soon the master is upgraded. If the buildbot  devs decide to
break compat between versions like this they probably had a good reason to do so. And this
problem should eventually also affect other ASF build slaves when they upgrade, so an upgrade
of the master looks like a somewhat inevitable prospect to me.

> buildbot 1.0.0 build slave not working
> --------------------------------------
>
>                 Key: INFRA-16332
>                 URL: https://issues.apache.org/jira/browse/INFRA-16332
>             Project: Infrastructure
>          Issue Type: Project
>          Components: Buildbot
>         Environment: OpenBSD 6.3 / sparc64
> buildbot-worker 1.0.0 installed via 'py-buildslave' OpenBSD package
>            Reporter: Stefan Sperling
>            Assignee: Gavin
>            Priority: Major
>
> After an upgrade to OpenBSD 6.3 the svn-bb-openbsd build slave is now running buildbot
version 1.0.0 (previous version was 0.8.12).
> I have re-created buildbot.tac from scratch and (after some failed attempts due to wrong
login credentials) the slave now starts and connects successfully.
> However, the 'cleanup' stage is failing with a Python exception:
> Eexceptions.AssertionError: Unexpected usePTY argument value: u'slave-config'. Expected
boolean
> https://ci.apache.org/builders/svn-bb-openbsd/builds/73
> Can somebody please help me figure out what needs to be done to get it working again?
> Perhaps the 'svn-bb-openbsd' configuration directives on the master need to be adjusted
somehow to work with the new version installed on the worker?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message